Icon is missing for window close in overview


I am running gnome 40 with testing and its super smooth and nice! Only issue is that since install, the icon is missing for window close in overview regardless of theme! No rush for a fix, I thought I’d just post so folks know! See attached screenshot!


That’s not stock, that’s Dash to Dock. FYI, the testing branch does not have all the GNOME 40 packages yet. Unstable does with WIP versions of Dash to Dock and Dash to Panel.

Ah got it! I switched to unstable and enabled Dash to Dock and Dash to Panel, but still no luck! Are you saying its caused by a lack of support from those extensions?



Sorry, the close icon on the overview is stock and should be there. Earlier I was thinking of Dash to Dock’s close option in the context menu.

My guess is the theme you’re using hasn’t been updated for GNOME 40 yet. Try Adwaita or Matcha.

Thanks for the suggestion! I’ve tried all the themes including adwaita and matcha (just tried them again to double check) and no luck! Also rebooted in-between theme applications a couple times and no luck on that front either!

Strange, the buttons appear for me when the mouse cursor is over an application.

1 Like

Gnome 40 looks so darn hot! :hot_face: :hot_pepper::hot_pepper::hot_pepper:

Yeah, it’s odd! I might just try a reinstall this weekend or something and see if that fixes it? Not sure what else could be going on? I’ve poked around dconf editor, but can’t even find a section for that part of the UI, so don’t really know where to start! Maybe just something wonkey I did around time of install? I’ll let you know what it’s like after reinstalling!

I have a similar (?) problem. If i press windows key, i can not go back to my home screen even if i press window key again.

@mgoldchild maybe this?

1 Like

@pobrn Ultra thanks :smile:. After disabling dash to panel from gnome-shell, my weird behavior was solved!

Eventually, my gnome UI became like below:

I’ve got dash to panel disabled but I still can’t see the dash in the dock. And the top bar changed to grey. :confused:

More people seem to have this issue, even with the new adwaita-icons-theme version 40 package from unstable.

Has this been fixed? I’m still having the issue but I can’t find any update on this

EDIT: I found out it was an issue with Loginized. I was using it to change GDM background and for some reason it was messing up gnome-shell’s theme. Switched to GitHub - realmazharhussain/gdm-tools: tools for Gnome's login manager to change background and everything went fine!

Hello everyone this issue is still relevant and ongoing on Manjaro ARM for the pi on a stock installation