Icecat build failing + torsocks?

I’ve become weary of being in Firefox’s hen house. So downloaded and extracted the icecat.tar.gz and then ran torsocks makepkg

Everything seems good until:

==> Starting build()...
Assertion failed in _parse_loader_output:
Traceback (most recent call last):
  File "/home/sadfa/icecat/icecat/src/gnuzilla-8b54aee6bd0c39f043bbba7a654870e032a910bc/output/icecat-78.9.0/python/mozbuild/mozbuild/", line 277, in read_mozconfig
    parsed = self._parse_loader_output(output)
  File "/home/sadfa/icecat/icecat/src/gnuzilla-8b54aee6bd0c39f043bbba7a654870e032a910bc/output/icecat-78.9.0/python/mozbuild/mozbuild/", line 405, in _parse_loader_output
    assert current_type is not None
Error loading mozconfig: /home/sadfa/icecat/icecat/src/gnuzilla-8b54aee6bd0c39f043bbba7a654870e032a910bc/output/icecat-78.9.0/mozconfig

Evaluation of your mozconfig produced unexpected output.  This could be
triggered by a command inside your mozconfig failing or producing some warnings
or error messages. Please change your mozconfig to not error and/or to catch
errors in executed commands.

mozconfig output:

161XXXXXXX WARNING torsocks[X083X]: [syscall] Unsupported syscall number 217. Denying the call (in tsocks_syscall() at syscall.c:567)



==> ERROR: A failure occurred in build().

My goal is to do everything over Tor and systems that are similar to Tor.

FYI, I aready tried torsocks pamac build icecat but could not access some server.

I am fairly new to AUR so sorry if I’m asked silly questions but I open the PKGBUILD file and it says the author in a comment which is nice to see. It also has a commit to fetch and SHA256es to check against. The one thing that I missing though is a cryptographic signature authenticating that this was really submitted by the maintainer. Did I missed something somewhere?

EDIT: I tried going to and I get the message in bold red letters:

No signature for icecat.tar.gz
  1. I don’t care about your connection
  2. My personal opinion is you should not abuse tor for package installation.

I don’t know why you blend in tor with this - the correct command to build would be

pamac build icecat

If you are going to do this the arch way - you should ensure the tools are in place, clone the PKGBUILD with git, cd into the folder and run makepkg -is.

$ sudo pacman -Syu git base-devel
$ git clone
$ cd icecat
$ makepkg -is

Or you could simply install the bin package

$ pamac build icecat-bin
1 Like

Hi @sadfa,

I vaguely remember also getting some kind of error while building/compiling Icecat, so I installed the binary. Much easier and doesn’t take a tenth of thee time. It’s available in the AUR:

$ pamac search icecat
icecat-bin                                                                                                                                                                                            [Installed] 60.7.0-2  AUR
Binary build of the GNU version of the Mozilla Firefox browser

So, you can just install that.

pamac build icecat-bin

Hope this helps!

Please check versions and pkgbuilds before reccomending them as GNU isn’t releasing precompiled version since some time, last -bin version is 60.7.0 while current is 78.9.0

I saw yes. And that is why I wouldn’t, at this moment, recommend it for primary use.

I still use my Firefox Developer Edition as my main browser. However, even if t IS a few versions behind, I think it’s still leagues ahead n a loot of categories.

@sadfa and everyone else regarding this, you could always contact the AUR package maintainer and ask them to upgrade it. I’m just not bothered at the moment.

The AUR for IceCat is not outdated because the upstream version is officially still at 60.7.0.

Apparently, “GNU seems not interested doing it anymore” (compiling the package and providing a binary).

Edit: This means, that contacting the AUR maintainer would be useless.

True, thank you!

I am not recommending anything - I responding to a build issue.

Justifying the usage of a given package - outdated or not - is entirely a user decision.