I5 430m Hd graphics video decoding

hi, i switched to manjaro a while back it is an awesome experience overall but one thing is bothering me although hardware acceleration is working but on firefox and chrome video decoding is disabled which results in high cpu usage in youtube for example which is horrible for battery. is there any way i can fix that any leads would be great vaapi doesn’t support my cpu

:+1: Welcome to Manjaro! :+1:

Please read this:

and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…


P.S. If you enter a bit more details in your profile, we can also see which CPU/GPU you have, …
P.P.S. Also please provide the output of the FireFox about:config section, filtered on gpu-process

What CPU do you have? Please provide inxi -Fxza


We have that link in the current forum as well

I did mention CPU in the title but there you go about:config and inxi sorry for not providing enough info

layers.gpu-process.allow-software	false	
layers.gpu-process.enabled	true	
layers.gpu-process.force-enabled	false	
layers.gpu-process.ipc_reply_timeout_ms	10000	
layers.gpu-process.max_restarts	1	
layers.gpu-process.max_restarts_with_decoder	0	
layers.gpu-process.startup_timeout_ms	5000	
media.gpu-process-decoder	false
System:    Kernel: 5.8.0-2-MANJARO x86_64 bits: 64 compiler: N/A 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UUID=c167685c-520e-42bf-b220-ea9e7abff0ec rw quiet 
           apparmor=1 security=apparmor resume=UUID=952f0c63-9801-42e3-a8ff-d79a5633d7cd udev.log_priority=3 
           Desktop: KDE Plasma 5.19.4 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: FUJITSU product: LIFEBOOK AH530 v: N/A serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: FUJITSU model: FJNBB06 serial: <filter> BIOS: FUJITSU // Phoenix v: Version 1.16 date: 08/19/2010 
Battery:   ID-1: BAT1 charge: 37.5 Wh condition: 41.8/47.5 Wh (88%) volts: 3.8/10.8 
           model: PAC PC-VP-WP93-01/OP-570-76968-01 type: Unknown serial: N/A status: Charging 
CPU:       Topology: Dual Core model: Intel Core i5 M 430 bits: 64 type: MT MCP arch: Nehalem family: 6 
           model-id: 25 (37) stepping: 2 microcode: 11 L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 18093 
           Speed: 1376 MHz min/max: 1199/2267 MHz boost: enabled Core speeds (MHz): 1: 1463 2: 1463 3: 1463 4: 1463 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel Core Processor Integrated Graphics vendor: Fujitsu Limited. driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:0046 
           Device-2: Quanta type: USB driver: uvcvideo bus ID: 1-1.1:3 chip ID: 0408:1fc3 serial: <filter> 
           Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: intel unloaded: modesetting 
           alternate: fbdev,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1280x720 s-dpi: 96 s-size: 338x190mm (13.3x7.5") s-diag: 388mm (15.3") 
           Monitor-1: LVDS1 res: 1280x720 hz: 60 dpi: 96 size: 340x190mm (13.4x7.5") diag: 389mm (15.3") 
           OpenGL: renderer: Mesa DRI Intel HD Graphics (ILK) v: 2.1 Mesa 20.1.5 direct render: Yes 
Audio:     Device-1: Intel 5 Series/3400 Series High Definition Audio vendor: Fujitsu Limited. driver: snd_hda_intel 
           v: kernel bus ID: 00:1b.0 chip ID: 8086:3b56 
           Sound Server: ALSA v: k5.8.0-2-MANJARO 
Network:   Device-1: Qualcomm Atheros AR9285 Wireless Network Adapter vendor: Fujitsu Limited. driver: ath9k v: kernel 
           port: 1840 bus ID: 03:00.0 chip ID: 168c:002b 
           IF: wlp3s0 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Fujitsu Limited. driver: r8169 
           v: kernel port: 5000 bus ID: 07:00.0 chip ID: 10ec:8168 
           IF: enp7s0 state: down mac: <filter> 
Drives:    Local Storage: total: 119.24 GiB used: 17.23 GiB (14.5%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda vendor: Transcend model: TS128GSSD370S size: 119.24 GiB block size: physical: 512 B 
           logical: 512 B speed: 3.0 Gb/s serial: <filter> rev: 6KB scheme: MBR 
Partition: ID-1: / raw size: 111.21 GiB size: 108.97 GiB (97.98%) used: 16.67 GiB (15.3%) fs: ext4 dev: /dev/sda1 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 8.03 GiB used: 579.2 MiB (7.0%) priority: -2 dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 60.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 189 Uptime: 54m Memory: 3.65 GiB used: 1.08 GiB (29.5%) Init: systemd v: 245 Compilers: 
           gcc: 10.1.0 clang: 10.0.1 Packages: pacman: 1251 lib: 349 flatpak: 0 Shell: Bash v: 5.0.18 
           running in: yakuake inxi: 3.1.05 

Oh woops, I didn’t realize the 430m was the intel chip. That’s old!

Unfortunately, the only hardware acceleration for firefox and chrome are via VA-API. Since your CPU doesn’t support it, you’re kinda out of luck here… Looks like Intel didn’t support it until Broadwell (2014).

Yea it is old indeed, haven’t used it since years, couple days ago i slapped in an old ssd and with linux it flies, unfortunately watching videos results in 30 40% cpu usage 1440p ends up in the 60s thought there is a workaround for that, thanks for your help

Hold on, it is supported if you look at the second line it is supported by libva-intel-driver which i checked is installed on my system both 32 and 64 bits now why it is not working?

I totally missed that… that you follow these steps for Firefox?


Also, VA-API for X isn’t available until Firefox 80, so unless you’re running the beta or dev version (firefox-developer-edition), you can’t do it. Or swap to Wayland.

Sorry! Missed that! :cry:

  • about:config is correct.
  • I know nothing about Quanta GPUs so cannot help you any further… :sob:
1 Like

Well i tried everything except switching to wayland i have no idea how to do that, is it working for you guys with iGPUs ?? and how to switch to wayland?

So it doesn’t work with firefox-developer-edition at all either?

Nop tried everything with correct variables and forced YouTube to h264 and still same thing

I tested on ubuntu chromium dev and it worked cpu usage dropped to 10%, back to manjaro i got chromium-vaapi to work but funny thing is that it uses 20% video engine on gpu and 50% cpu so by enabling it things got worse on mpv same story high cpu usage even if video decoding is working confirmed by intel_gpu_top something is not right in Arch