I3wm | How to launch steam?

I feel particularly dense at the moment, but whenever I try to run steam it outputs the result below and does nothing. Am I missing something? Steam isn’t showing up in pgrep either. I had success installing the regular steam-manjaro package in a separate KDE (desktop) install, but on i3 (laptop) it’s not working. I saw a couple of threads here on google with this error, but clicking on them shows that they have been deleted.

Terminal output:

[asdf@ALaptop /]$ steam
/usr/lib/steam/steam: line 212: /home/unowen/.local/share/Steam/steam.sh: Success

Oh, also if I run steam as root a window pops up stating that the app can’t be run as root. Xprop states that it is a zenity window.

Welcome to the forum! :slight_smile:

With the double disclaimer that I don’t run i3wm ─ I run KDE Plasma ─ and that I’m not a gamer, the commands used by the Steam launchers in the menu are…

steam-runtime %U

… and…

steam-native %U

… whereby I presume that %U is a placeholder for the name of a file that launches a game. I’m not familiar with how it works, and I only have it installed because it came installed by default when I installed Manjaro in April 2019. :man_shrugging:

I only mention i3 as I had a KDE install on a desktop where steam worked flawlessly. The only two differences were the different DE and the fact that I didn’t have to use nvidia-prime on the desktop.

Interestingly the desktop file created by steam in the i3 version just runs the /usr/bin/steam command.

Also, just spun up a VM with the KDE iso. Running just “steam” in the terminal launches the login window, and does not have the “(SOME PATH)/steam.sh: Success” line anywhere. Same behaviour is seen with steam-runtime and steam-native.

Well, Manjaro i3 is a community release, not an official release, and i3 isn’t exactly known as an environment for gamers. I can only speculate, but maybe the desktop file in the i3 release is incorrect, and then the maintainer ─ I don’t know who on the team puts the i3 edition together ─ needs to be informed.

Edit: I’ve invited the maintainer of steam-manjaro to the thread. :slight_smile:


Other than nuking ~/.local/share/Steam/ and trying again, I’m out of ideas.

WARNING: If you’ve installed games, backup ~/.local/share/Steam/steamapps/ first.

That isn’t much of an error to go on.


Thanks! I have the updates now. I had that folder from ~2017 and always had this issue. Turns out after reinstalling 3 times I assumed the folder would have been deleted. Deleted the folder (~/.local/share/Steam) and installed and now it works!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.