I3 rookie need help

Willing to try out suckless window manager system I install Manjaro i3
uninstalled xfce probably won’t need that anymore
can you now tell me how can get rid of that palemoon browser always opens after pressing mod+f2
tell me the way to uninstall , I don’t like it
I tried every available guide in Manjaro forum to change pale moon browser
infact changed i3 config file and exec set to firefox instade of palemoon
but yet it bugging me and comes to fire me .
tell me how to uninstall and set firefox for mod+f2
how to activate natural scrolling and speed up scrolling with trackpad?
I will deal with other stuffs
but please I want to get rid of that palemoon seriously

I’m not so sure that that is the path to achieving this goal
given the Manjaro i3 … pre configured … configuration

suckless is part of it?

perhaps - but did you really uninstall it, leaving no presets around?

… palemoon …

You can’t uninstall it?

I can’t.
How did you install it?
… just uninstall it that same way …

But perhaps you should investigate how the keyboard shortcuts work and are configured in i3.

… or how anything works and is configured in i3 … :wink:

1 Like

Sir I install i3 from iso means it’s a fresh install
oops very sad to know palemoon I cannot uninstall it

can you please tell me how to activate natural scrolling using trackpad?
or can you tell how can i access manjaro settings gui version? then i can do stuffs my own

I could probably survive when I had to use i3
if I for some reason had to …
I did use i3 gaps a couple of years ago.

… not what I call comfortable
but one can learn and live with it

others even love it for the efficiency that I just cannot harness …

I cannot tell you anything but:
learn how to use it if you want to use it
or
don’t use it.
Simple … :wink:

no, I can’t
not without researching that very topic myself :wink:

the GUI is started via a command.
I could find out what that is - but so can you. :wink:

In i3 there is no menu or application starter - so you use the command.

You don’t know it?
You can’t find out?
not a problem whatsoever!

… just don’t use i3 -
learn Manjaro/Arch/Linux with a more approachable Desktop Environment
like Xfce or even just OpenBox (which isn’t a DE, but a window manager …)

How about you tried:
manjaro-settings-manager :wink:

1 Like

Hello @raj-rup :smiley:

Can you post the config to let us know more?

if you installed i3 from pacman, palemoon shouldn’t be installed with it. but you used the iso so the config would be really helpful.

try out @Nachlese suggesstion from terminal … or if you want a menu system you need to install something like dmenu (suckless program) or rofi and add a key bind in your config file. as you installed from the manjaro iso, you should check their pre-installed packages first, something should be installed.

as far as my knowledge goes i3 is not a suckless utility. :wink:

1 Like

if you already have firefox installed, adding

bindsym $mod+F4 exec firefox

to the config file, will bring up firefox on pressing mod and F4 (after you have reload the i3 config or restarted i3 )… you can check if this works…

1 Like

I am not going to give up .
Because I already love it.
I am gonna dig through this problem .

manjaro-settings-manager I already tried , it not a know command

sir I already notice that firefox issue is fixed
you need to fully shutdown your system then changes will take effect , because i restarted several times nothing worked .
after a cold start it worked

sudo pacman -S manjaro-settings-manager
1 Like

I download the minimal iso , made my usb bootable using usb imager on gitlab,
I don’t use eacher because for data snooping matter and I don’t want any prying eyes .
I am trying to debug the issue.

and I just notice palemoon problem fixed

you need to shutdown your MI3 system and then start it and then the settings inside config file takes effect

1 Like

Use Mod+Shift+R to reload i3 config file. No need to restart.

2 Likes

after a cold start all settings has been applied , restart didnot work but had to shut my Laptop down and power it up and the key bindings and the changes are working

okay SIr , you understand sir I am a rookie so I don’t know much but kinda love it .

can you please tell how to speed up track pad and opted on for natural scrolling?

@raj-rup Follow these guides:

https://wiki.archlinux.org/title/Mouse_acceleration

https://wiki.archlinux.org/title/i3#Keybindings

1 Like

by restarting i3 i meant what @ishaanbhimwal suggested later…

good to know that your issue is solved

1 Like

You really should post your config-file (probably ~/.config/i3/config) So we could look into it and help you further.
If you don’t have any local config for your user in the system, you could copy the default file from /etc/skel

cp /etc/skel/.i3 ~/.config/i3

No need to uninstall palemoon. But if you so want you could type the following in the terminal.

sudo pacman -R palemoon-bin

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.