I think I have an "idle cpu" issue

System specs.
Dell Optiplex 7090 Micro w/ Intel i5-11500T (UHD Graphics 750)

This is a secondary PC on my desk, what I’m trying to do is control it using the keyboard/mouse on my main pc (Windows 10) with Barrier. The issue I’m having is that when my dell micro pc is idle, barrier frequently disconnects, and mouse movement will be jerky and keyboard inputs will sometimes be ‘lost.’

I originally thought it was a networking issue, because I noticed that if I had a video streaming on the Dell micro, that barrier would work great with no disconnects or lag. So I first tried disabling the power saving capabilities of the e1000e network driver, which had no effect.

Later, I happened to notice that just having OBS open on the dell micro also seemed to resolve the Barrier connection issues. With OBS open, not streaming or recording just open showing the canvas, the system sits at ~5% cpu use. This made me think the issue could be cpu idle related. To that end I then tried playing a video file in vlc from the local disk. This had the same effect of stabilizing the Barrier connection.

Now, with that in mind I tried setting intel_idle.max_cstate=0 which had no effect on the issue at all. I’ve also tried intel_pstate=no_hwp (with and without intel_pstate=active), as well as simply tried intel_pstate=disable

I’m able to tell from dmesg output after rebooting that all of these settings are being applied at boot up, but none of them have had any effect on the stability of my Barrier connection between the two PCs. The only “fix” seems to be running some application on the dell micro PC to keep a load on the cpu.

I was having the issue on the 5.13 kernel that was included from the Manjaro installation media, and I’ve since updated to 5.14 with no change in this behavior. Anyone have any other troubleshooting ideas?

inxi -Nxxxz -Cxxxz -Gxxxz
  Info: 6-Core model: 11th Gen Intel Core i5-11500T bits: 64 type: MT MCP
  arch: Rocket Lake rev: 1 cache: L2: 12 MiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  bogomips: 36300
  Speed: 1070 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 1070 2: 1726
  3: 1399 4: 1123 5: 1055 6: 1399 7: 1392 8: 1612 9: 1480 10: 1164 11: 1343
  12: 1114
  Device-1: Intel RocketLake-S GT1 [UHD Graphics 750] vendor: Dell
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:4c8a class-ID: 0300
  Device-2: Logitech C922 Pro Stream Webcam type: USB
  driver: snd-usb-audio,uvcvideo bus-ID: 1-1:2 chip-ID: 046d:085c
  class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org 1.20.13 compositor: xfwm4 v: 4.16.1 driver:
  loaded: modesetting alternate: fbdev,vesa resolution: 2560x1440 s-dpi: 96
  OpenGL: renderer: Mesa Intel Graphics (RKL GT1) v: 4.6 Mesa 21.2.3
  direct render: Yes
  Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iwlwifi v: kernel
  bus-ID: 00:14.3 chip-ID: 8086:43f0 class-ID: 0280
  Device-2: Intel Ethernet I219-LM vendor: Dell driver: e1000e v: kernel
  port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15f9 class-ID: 0200
uname -r

I updated the system in question yesterday to the 5.15 kernel now available on the stable branch, and knock on wood that seems to have largely resolved the issue. There is occasionally still a bit of cursor lag when first transitioning from my primary PC (Win 10) to the Manjaro secondary system, but this very well could be a symptom of barrier itself (I’d always used Mouse Without Borders in my all-windows setup before).

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.