I run startx and now the laptop is stuck at login

Hey guys i was searching how can i get rid of tearing in my old lenovo laptop running intel 3000 , and then i typed startx and that is when i wasn’t able to login normally since my screen got stuck at login …
it only work when i open terminal with ctrl + alt + f3 and type startx and interrupt it with ctrl + c since it gives this when i run : xauth: /home/darkuni/.Xauthority not writable, changes will be ignored

Please help me restore my old configuration (not i am still a newbie please go easy on me)
note : my DE is kde plasma with X11

it appears you have run startx as root (using sudo) - don’t.

sudo rm -f ~/.Xauthority
1 Like

i run startx again without root and this is what i get

xauth:  timeout in locking authority file /home/darkuni/.Xauthority
/usr/lib/Xorg.wrap: Only console users are allowed to run the X server
Couldn't get a file descriptor referring to the console.

modified : nvm after deleting that file and restarting the laptop everything works good as intended thank u very much

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.