I royally screwed up VLC

Hi All,
I don’t know if this is the proper place for my post, my apologies if it isn’t. Please be patient with me, I’m new here.

Let me start by saying that I did try to Google and Search the forms for an answer but I did not find one. If I have missed it, kindly point me in the right direction.

So I am running the KDE version of Manjaro and I set up VLC to autostart. That was working just fine, but I wanted it to start in minimal mode. I couldn’t find a way to do that but found these instructions and followed them " Tools → Preferences… (Show settings: All) Interface → Main interfaces… → Qt and Selection of the starting mode and look"

The good news is it works in that VLC instantly minimizes (it disappears).
The bad news is VLC doesn’t work and I cannot access it.
When I try to open it, it promptly disappears.

I tried to uninstall it but I can’t do to a dependency issue (another program relies on one of it’s dependencies and hence it won’t uninstall).

I have tried reinstalling, rebooting and no joy.

Does anyone know how I can fix this short of reinstalling Manjaro?

rm -r ~/.config/vlc/

@ben75 you are the Man!!!
Thank you so much for your help, I greatly appreciate it!

Any chance you happen to know how I can make VLC autostart minimized?

I don’t know whether this applies for vlc — I haven’t tried it yet — but some applications remember their last state. For instance, if juk and telegram-desktop are minimized to the system tray when they are closed, then they will restart minimized to the tray the next time.

1 Like

I tried that but unfortunately it did not work.

This should do it. Autostart it instead of vlc.


xdotool search  "VLC media player"  windowminimize

If you want it minimised to the systray then:

Interface → Main interface → QT → Start VLC with only a systray icon

@dmt thank you for your help, it is appreciated.

I’m putting my Newbieness on full display here, I’m not sure what to do with the code you’ve kindly provided (I tried the first line in a terminal but you can guess what happened).
I’m guessing that code is a script?
Ok, I think I was able to make that an executable script and select it as Autostart at Login.
Fingers crossed, I’ll give it a try next.

Setting the interface to QT is what got me into trouble with VLC. I have VLC autostart and automatically play a stream when I boot into Manjaro.
When I set the main interface to QT, not only do I lose access to VLC, it does not play the stream. It remains hidden and silent.

No Joy, VLC did not autostart with that script.
Was there something wrong with the steps that I took?
-made an executable script
-selected it as “autostart at login”

Sorry I should’ve been clearer, but sounds like you figured it out. However the script does start vlc for me.

I must admit I didn’t test it, and I was clearly half asleep as there’s a typo that means the second line can’t run until vlc is shut down.

Here’s a better version, it works here. You can play around with the sleep time, but 1 wasn’t enough for me.


sleep 5
xdotool search  "VLC media player"  windowminimize

The idea behind starting vlc in the same script was to help with timing, ie the second line would run after the first.

However since we need a delay anyway, you could auto start vlc as before and remove vlc&. This may work better for your use case.

If you’re referring to the suggestion to “Start VLC with only a systray icon”, then there’s only an icon in the systray until you click on it.

What interface are you using then? The GUI is QT.

I haven’t used vlc in years and even then only with local files, no autostart, streams etc.

Your best bet is to use a playlist:

  1. Open VLC and go to the Playlist tab
  2. Right Click and Advance Open
  3. Add your stream info and click select

Now your stream should show on the list of Playlists.
Right Click on your stream and “Save Playlist to File”

Now you can use the xspf file to start the stream in VLC, just make sure VLC is the default to open .xspf files.

I tried the new script, minus the "VLC& " and no joy.

Yes, that is exactly what I would like to happen.

The main interface is set to “Default”.
When I change it to “QT Interface”, VLC closes instantly and does not automatically play the stream (the stream is automatically played now, that isn’t a problem).
It is also impossible to make VLC appear on screen when QT interface is selected.
While I do want VLC to start in the systray, if I do need it, say to change the stream, it is impossible to do so without being able to access VLC.

I actually do have VLC currently starting and automatically playing my stream. The issue is if I set the main interface to QT, VLC disappears instantly and it will never appear on screen when you click on the icon. It also does not play the stream when QT interface is selected.

Do you have xdotool installed?

pacman -Qs xdotool

If something isn’t working in autostart, test it in the terminal…you get error messages. Anyway from what you’ve said, this isn’t the solution you’re looking for.

So is mine, and I didn’t say change the interface. Have you tried to “Start VLC with only a systray icon” yet?

If it breaks again, you know how to fix it again. :slight_smile:

I don’t see that option anywhere (I looked in Preferences and selected show All).

I do have “Show systray icon” enabled, while that shows the icon in the systray, VLC still launches fully.

I think this is one of those things that I’ll just have to live with.
I used to have it open only in the systray in a previous distro that I used to use, but that was a long time ago and they’ll likely changed VLC since then.

The topmost checked checkbox in the pic. :smiley:

That is very different than what I see.
I’m running KDE if that matters.

Here’s a screenshot of my VLC menu:

There’s an arrow next to “Main Interfaces”, click it, then select “QT”, etc

1 Like

Nevermind me, I just found how to get to that menu.
I’m learning…
Many thanks again for your help @dmt I really do appreciate it!

1 Like

That was MAGIC!!!
Now it automatically opens only in the Systray and plays my stream.
A million thanks @dmt!!!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.