I need wxwidgets-gtk3 3.2.0-3 or higher in order to compile wxmaxima 22.05.0-3

Hello team,

I need wxwidgets-gtk3 3.2.0-3 or higher in order to compile wxmaxima 22.05.0-3.

Otherwise, are now wxwidgets-gtk3 and wxwidgets-gtk2 became incompatible?
woeusbgui requires wxwidgets-gtk2 (or wxgtk2) which now cannot be installed when wxwidgets-gtk3 3.2.0-2 is installed because wxwidgets-gtk2 and wxwidgets-gtk3 use the same /usr/bin/wx-config file.

Manjaro Stable and Testing branches have v3.2.0-2, but Unstable branch has v3.2.0-4
wxwidgets-gtk3 | packages.manjaro.org

This update breaks espanso.
I have the following message if I try to launch it:
espanso: error while loading shared libraries: libwx_gtk2u_html-3.0.so.0: cannot open shared object file: No such file or directory
I think it is linked with the wxgtk2 removal, but I don’t know how to fix it. Any suggestion?

Rebuild espanso?

I had the same problem with codelite, had to rebuild that one


Oh didn’t know about that. Thank you very much, I rebuilded espanso, now it works :smiley:

I’m facing the same issue. Sorry for the elementary question, but how exactly can I rebuild espanso?

Simplest is with pamac gui, find espanso and click on the espanso line. click on build and apply changes.


Solved by wxwidgets-gtk3 upgraded to 3.2.0-4 version and replacement of woeusbgui by woeusb-ng.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.