I need to add a file to the EFI/BOOT on the ISO

Ok this little ASUS T100 netbook runs all kinds of linux but I need to pay attention to the ISO. To boot I always need to a file to the EFI/BOOT and that file is Bootia.32.efi.

Why you may ask?

This ASUS is a netbook and the hardware is able to run 64-bit software but the UEFI is 32-bit. Yep it is a strange little thing but as a toy, as a netbook it works fine.

For some reason Manjaro hides the files where I need to add the file — well hides isn’t the word. Manjaro seems to lock down the ISO so that I get a message there there is no room on the flash drive. On a 64 gig drive…no more room?

I already know the procedure of getting the broadcom wifi up and running by getting the files from Git. Or at least I’ve been able to get other distros to work using the protocol.

What I need at the moment is to be able to add the file.

Help is appreciated.

Hi and welcome!

How did you write it to the usb stick?
If with dd, then it is readonly.

Btw… you cant put a file into a ISO. You need to extract it, add the file and recreate the iso.


I use both Belcher or Rufus.

When I am given the choice I chose GPT (MBR is a no go) and as for coping a file to a folder in the ISO , I do it all the time when I have to deal with the ASUS crazy 32/64. Just did it with Ubuntu Mate 20. At first I forgot to add the file and tried to boot the stick. No go. Then I remembered I didn’t copy that bootia32.efi file.

Yeah I know, I was always under the impression that you couldn’t copy a file to an ISO but maybe that is more true with a CD .

I’m still trying to get the silly ASUS to boot my Ventoy stick.

The biggest problem with the little toy is the wifi when running a live version. Some distros have the correct wifi driver on it and some don’t. Mint 20 Mate has it but LMDE 4 doesn’t have it.

Ventoy uses it the last partition on the stick as efi partition. It is only 32M so there is very little room for extras.

So that’s why I can’t squeeze anything in there. :wink:

Try these instructions at the archived forum. The standard Manjaro ISO format is a read-only image. The guide makes the liveUSB another way.

Thanks. That link is interesting and I’m going to give it a try.

1 Like

Well I tried it twice, followed the steps but the USB will not show up. Maybe my BIOS is older than that in the instructions. But I gave it a try and thanks for the info.