I need help with mkinitcpio.conf.pacnew

Hello
here is what i got(right side is the pacnew):

what should i do?
i don’t know what any of these mean,but i see the new one is missing : “keymap” & “resume”,and adds “fsck”.

and about this:

# MODULES_DECOMPRESS
# Decompress kernel modules during initramfs creation.
# Enable to speedup boot process, disable to save RAM
# during early userspace. Switch (yes/no).
#MODULES_DECOMPRESS="yes"

i dont’ mind my current boot speed but i also have enough RAM.
any downside to enabling it?

That should be:

HOOKS=(base udev autodetect modconf block keyboard keymap resume filesystems)

Rest just leave it default.

2 Likes

what is this new “fsck” i’m missing?

Have a look here:

https://wiki.archlinux.org/title/Fsck

The fsck hook is standard, I would recommend to add it at the end.

Your hooks line could be changed to look like this:

HOOKS=(base udev autodetect modconf block filesystems keyboard keymap resume fsck)
1 Like

It is checking filesystem. But I think it supports ext4.

1 Like

so we didn’t have fsck before this updtae?
@Zesko i use ext4.

In earlier Manjaro times fsck was skipped, I think shutdown was sometimes a bit faster and less messages, but Arch standard is to have it set. In fresher installs it is set in Manjaro, too.

1 Like

and what about

?

what did you choose?

No need to change as it’s all behind #, means only a comment, has no effect. If you want you can copy the paragraph to the new conf file.

i just saw this comment:

" Hello,

I just updated, restarted and all is good. Made sudo mkinitcpio -P restarted and all is oki.
This is my hooks line

HOOKS=(base udev autodetect modconf block keyboard keymap resume filesystems)

All the options are commented in the file so its not difficult to understand.
I don’t have fsck option because /usr is not in different block so I don’t need it."

do i need to run this command?and aslo his comment about “/usr is not in different block so I don’t need it.” what does that mean?

Please read description of hooks here.

NOTE: These are just scripts that tell mkinitcpio what to include/load/run in initramfs.

1 Like

it says about fsck: " The use of this hook requires the rw parameter to be set on the kernel command line"
how do i do that?

Edit:
i think i’ll skip all that and stay with the current defaults.

You linked yourself to the kernel parameters wiki article, why do you need someone else to tell you what it says there? :stuck_out_tongue:

Anyhow, you don’t need to change anything, you only need to have commented out #GRUB_ROOT_FS_RO=true in /etc/default/grub which you most probably already have.

2 Likes

Because @linub just doesn’t give a fsck.

(I’m sorry. I just had to use that line after reading through this thread. I kept biting my nails, trying to resist the urge, but the more I kept reading the posts, the stronger the temptation… :confounded: )

do i need to run any command like the one i mentioned above( sudo mkinitcpio -P) after adding fsck to mkinitcpio.conf ?

Any time you make a change to /etc/mkinitcpio.conf you must run mkinitcpio -P

Any time you make a change to /etc/default/grub you must run update-grub

1 Like

Thank you everyone for the help provided.
it’s much appreciated.