I need Help fixing nvidia driver issues. After update attempt, system boots to black screen with no access to grub or tty

I have been trying to solve this issue for a while and I have made some discoverys but no solution.

Using manjaro, kernel 5.8 and nvidia 1660 ti.

it started when I tried to update my nvidia driver from 450xx to 455xx from the terminal. I also updated my system at the time. When I rebooted it booted to black screen and I could not get to grub or change tty.

I have downloaded a manjaro architect iso to do some system rescuing. I have tried to chroot into the system and use ‘mhwd -r …’ to remove the nvidia drivers, removing everything i see when i run the command ‘pamac list --installed | grep nvidia | grep -v mhwd’, so video-nvidia drivers and also installing and removing the video-linux drivers, that have been there.

i first was trying this troubleshooting solution from the manjaro wiki:

i have been through the arch wiki page for troubleshooting nvidia, trying all the solutions that might fit my issue.

xorg logs say the kernel module ‘nvidia’ is uninitialized

I have tried to run ‘modprobe nvidia’ to start the nvidia driver, but this fails because I am using a live usb with a different kernel than mine (i use 5.8 and 5.4, the usb has 5.6 by default).

after everything i do i try to reboot from ssd and i see a blank but lit screen. the fans cycle up, then down then up which is exactly normal as far as i can tell. I am unable to tab shift to get into grub and cant ‘ctrl+alt+f2’ to a different tty.

inxi -G shows me drivers: n/a but tells me the right gpu.

mhwd -li shows me that i have installed the 455xx driver.

I dont see any nvidia modules under /lib/modules/(kernel version)/kernel/driver/video

lsmod | grep nvidia shows me i2c_nvidia_gpu

I ran journalctl -xb -1 and somehwhere in the middle found the lines of errors ‘failed to look up module alias ‘vboxdrv’: function not implemented’ and it had the same error line for ‘vboxnetadp’, ‘vboxnetflt’, ‘nvidia’, ‘nvidia-drm’ and ‘uinput’.

How can i load those modules, especially when i can only access the system through chroot, which has the 5.6 kernel?

That kernel is EOL (End Of Life) and hasn’t received security updates in awhile. You’ll need to install 5.9 (current stable) and/or 5.4 (LTS) from Manjaro Settings Manager > Kernel.

Please see the following:

Use a newer ISO. Every official ISO edition contains Architect if you want to install that way.


Thank you I will follow this advice and start with a newer iso. Can I upgrade the kernel from chroot, or should I be doing this from the installer maybe?

Boot a newer ISO, choose proprietary drivers (non-free) from the GRUB menu, then install with Architect from there.

thank you, this ended up being the most pain free route, where i have just backed up my /home directory and made a fresh install. You manjaro people make this community great btw!!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.