I need advice for a LADSPA plugin that can delay audio

I am using Kde Manjaro Plasma (latest updates) and I have a system wide equalizer installed, which works perfectly. Great stuff! It is called Pulse Audio Equalizer-LADSPA.

My problem: I would really appreciate any advice about a LADSPA plugin that could delay audio. There are so many of them that I dont know how to start searching. Any other suggestion of how to delay audio input (system wide) would be appreciated very much as well.

KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2
Kernel Version: 5.9.16-1-MANJARO
OS Type: 64-bit
Processors: 2 × Intel® Core™ i5-3320M CPU @ 2.60GHz
Memory: 3,5 GiB of RAM

sudo pacman -S lsp-plugins


1 Like

pulseaudio-equalizer-ladspa depends on package swh-plugins for the equalizer plugin

swh-plugins also has a delay plugin ( /usr/lib/ladspa/delay_1898.so) but you probably do not need it

I do not see why you would need to delay audio system-wide
But you might want to add a delay offset for one output device to synchronise audio with another device

I suspect that KDE audio controls do not have access to latency offset controls, so you may need to install pavucontrol-qt to access these controls

(click on the :arrow_forward: to open advanced settings)

pavucontrol latency

1 Like

Thanks for the advice Aragorn and nikgnomic. Sorry for my late reaction. I did achieve some meaningful success, but I still have got a small but annoying problem.
I would be very grateful if you could help me out with that.

The problem:
Latency offset settings seems to be limited to -100 milliseconds max in Kde.
And I need a latency offset lower than -100 milliseconds in Kde. Even in Xfce Manjaro, wherein I CAN put a lower latency settings than -100 milliseconds, (for example - 200) there still is no noticeable difference compated to -100 milliseconds in Xfce. Below -100 latency, no matter what setting I put in, there is no further audio delay possible.

I watch television on my computer. My internet provider shows the televion programs with an annoying audio delay. This has been a problem for 3 years on end, but they dont fix it, even after many complaints by many users.
It is not a system or browser specific problem. Folks in my country with Windows/Apple and who are using Chrome are reporting the same audio delay problem as I have with Linux and Firefox.

I do already have swh-plugins installed. Could you explain to me how I activate this /ladspa/delay_1898.so delay plugin you were referring to? I can see that it is present and installed in my Kde system and also in my Xfce system, but how do I activate or use delay_1898.so ?

I dont have lsp plugins installed. Is that collection of plugins also neccessary to achieve a working system wide equalizer with an audio delay? I would be very grateful for any further advice, because I desperately wanna be able to watch television without the annoying audio delay.

The screenshot shows a - 150 latency setting, but even if I set it to any other number lower than -100 there still isnt any change in latency. Only different settings between zero to -100 cause a noticeable change. For example: I have tried setting it to -3333. No noticeable difference whatsoever compared to -100. The latency does change sonically though when I put the latency into PLUS settings, like + 200 or + 500 etc. That does make a noticeable difference. But I only need a negative latency setting of about -150 or - 200 to achieve perfect audio sync. That is my problem in a nutshell… :frowning:

It is not possible to add negative latency
PulseAudio can create a virtual negative latency offset by reading the audio buffer for the offset device before the other devices
Setting Latency offset below -100mS is probably just increasing the buffer size and delaying other audio outputs more to create audio stream delays

Latency offset to synchronise audio streams within PulseAudio is not going to mitigate for the audio delay from the internet provider unless the situation was reversed and video was delayed compared to audio stream

Thanks again for your advice nikgnomic!
Yes, like you mentioned above, I think that is the case: video is delayed. Audio comes first and then I see the mouths moving too late. I must have posed my problem incorrectly before. Apologies. Or maybe I am wrong again?

But what I need is some sort of adjustment, so that the audio is synced with the video. Is such an adjustment still possible? Via virtual latency or via another equalizer plugin?

It is the audio source from Firefox which has to be delayed a few milliseconds (-150 or something) before it hits my headphones output. I can use Xfce Manjaro or Kde Manjaro to experiment with, whichever is easier.

If I can solve this problem, I can and wlll share the solution with many Linux users in my country, who will be very happy, because this problem has been going on for 3 years with my internetprovider. I stopped watching television altoghether, so I really hope there is a fix possible… :smile: