I’m trying to get Manjaro installed in the Emmc on the OP4 LTS

Heya, I know it’s been a while since anyone has posted here, I’m trying to get Manjaro installed in the Emmc on the OP4 LTS. I’ve tried the Manjaro Arm installer, I’ve tried DD-ing a currently running img, but nothing seems to boot. Is there any way you could help me with this or is it an impossible situation. The OS runs from a MicroSD card but not the Emmc. I don’t know what I’m doing wrong. I’ve tried using a running system on the MicroSD card to Etcher a fresh image to the Emmc , but that didn’t work… I noticed above that it takes melding the Armbian bootloader and a Manjaro image… I don’t know how to do that, but I’d appreciate any assistance please.

Hello Welcome to the forum,

what do you mean by not working, Is there any error when flashing or does it flash the os img to emmc but never boots?

can you provide bootlog when booting from emmc ?

1 Like

Heya, Ok… I’ve used the official manjaro-arm-installer to image the OS to the Emmc. I did this from a working instance of the OS on a MicroSD card inserted into the boards slot (which boots, but shows a manjaro uboot screen very quickly before booting properly via MicroSD card). This files write to the Emmc, they are visible on the drive using thunar file manager, and they seem to match the files used on my MicroSD cards version of the same OS. but…when i power down and remove the MicroSD card then repower the system, it just shows a black screen and seems to do nothing…… i can also see using fdisk -l two small mmblk1boot1 and mmkblkboot2 partitions, i dont know if they might be causing issues… I’m stumped

If you can provide some bootlog while booting from emmc then it will be helpful to understand the issue.

Heya Mr Spikerguy (cool name by the way:-) ) I would love to provide the bootlog, but as I can’t get the machine to do anything while booting from the Emmc, I don’t know how I’d do that. How do you get a bootlog from the device when it won’t respond to any inputs and refuses to create any output display… It’s like it doesn’t even know there is an Emmc attached and just sends power to the GPIO and the USB ports. Is there a way to retrieve the bootlog from a previous boot attempt from the Emmc when booting from the MicroSD card slot…if so I’d be only to happy to provide what you need:-)

Thanks again for your time and help buddy…

I think you need uart cable to connect to uart debug pins and usb in your normal computer and read both logs that way.

Ok… I am now at an area of knowledge where I don’t know what to do … I’ve never used UART or anything like that before… So, it may be a while if ever I can get that to you… I am sorry for this, I just don’t know what to do with UART enough… I still hope this can be remedied… (He hopes with massive respect)…


I will get to try it the way you did and try to recreate this issue.

I can only do that during the weekend.

Thanks good sir, I really appreciate all your time and efforts. Whatever you can do would be amazing and I hope this gets resolved :slight_smile:


I found the reason for it not booting from emmc.

Wow… That was quick… What is the issue stopping the boot process? Is it easily fixable or is it something that will need to be worked on over time? Thank you again for your help:-) you seem to be the guy with the skills in Manjaro Arm:-)

uboot is not able to find emmc on boot.

I am looking at the solution.

Once I find the solution I will create a new image for you to use.

That would be amazing, Thank you so so so much… I also would like to ask if there is an image in the works for the Orange Pi 5B too? I fully understand that is a new board and it’s very very early in its dev cycle, but just wondering:-) thank you again good sir… You are a seriously brilliant help :slight_smile:

No, it will not work on opi5 board. For opi5 there is a different image but there is no HDMI out on opi5 image on mainline kernel yet.

OPI4-LTS Update: I have triggered a new image build with the fix. You can get the latest image from github release link here

You should see todays build and give it a try. I have tried it on my device and it boots via emmc without any issue.

Good Luck.

Give it a try

1 Like

Hey buddy, just wanted to say I installed it last night and it works like a charm. Got me some KDE goodness running on X11 (cuz I use barrier for keyboard sharing) and it’s all working… just to set up my apps and customise it with my icons and stuff… But works like a dream:-) Thank you so much for your help and support. I have to say, I am glad I chose Manjaro as my go-to Distro:-)


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.