I installed manjaro using Chinese and now can't set all softwares to English

Hi, I installed manjaro (KDE) yesterday. During the install guide I chose Chinese as system language. Now I want to switch to an English user interface, but after I made these changes:

  • KDE regional settings, put American English first
  • locale, set LANG=en_US.UTF-8
  • ~/.config/plasma-localerc, set Format.LANG to en_US.UTF-8

some program are still displayed in Chinese:

  • pacman
  • “Add/Remove Software”

What should I do to get a totally English interface?

Welcome to the forum!

Perhaps this will help… :arrow_down:

Don’t forget to log out and log back in, or alternatively, reboot. :wink:

$ cat /etc/locale.conf 

$ echo $LANG

I think most of my settings are correctly set to en_US.UTF8, except for this one

$ localectl
   System Locale: LANG=en_US.UTF-8
       VC Keymap: cn
      X11 Layout: cn

I’m checking how to change X11 Layout

for pacman and all other CLI software:

vim ~/.bashrc
add one line:
export LANG=en_US.UTF-8

I have changed $LANG, you can see the floor above.

also this does not work for me

$ LANG=en_US.UTF-8 pacman
错误:没有指定操作 (使用 -h 获取帮助) 

Found it works for pacman after I set LANGUAGE=en_US. Will modify ~/.config/plasma-localerc and log out later

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.