I installed Manjaro on a USB, worked for a whole year, now it won't boot

Since last year, I’m always installing Manjaro on USB sticks (Samsung Fit usually) and this has worked fine with two PCs and two laptops…no complaints.

The trouble started when trying to boot up a laptop I haven’t used in a few months. It’s a touch screen (has always worked with Manjaro) and while it was booting I was wiping off the fingerprints. Manjaro booted with some kind of “screen error” so I assume it was due to me cleaning off the screen during the boot process. So I rebooted and the desktop came up, but it seemed to be frozen… So I rebooted again, this time the desktop did NOT come up.

Then I tried booting the fallback kernel or whatever it’s called–that WORKED. I don’t really know what I’m doing at this point, but I figure OK I need to upgrade the system, so I did pacman -Syu and I thought it was working… but then I look down and see a ton of “read only” errors. Now I’m thinking… maybe I just need to remove the write protection? I tried a couple of commands on another PC to remove the write protection–nope it still won’t boot. Now I’m wondering if my system is bricked/gone…

I can’t mount the USB, the error is something like “no superblock” so I try a half dozens commands to find the superblock. Apprenly I have no superblock. No secondary superblock. fsck doesn’t work either.

fsck from util-linux 2.36
e2fsck 1.45.6 (20-Mar-2020)
ext2fs_open2: Bad magic number in super-block
fsck.ext2: Superblock invalid, trying backup blocks...
fsck.ext2: Bad magic number in super-block while trying to open /dev/sdc

The superblock could not be read or does not describe a valid ext2/ext3/ext4
filesystem.  If the device is valid and it really contains an ext2/ext3/ext4
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>
 or
    e2fsck -b 32768 <device>

/dev/sdc contains `DOS/MBR boot sector' data

I would think OK maybe it’s damaged. The usb gets REALLY HOT, I would not buy plastic SanDisk storage again… Anyway, I’m not giving up yet because the USB will still boot to the Manjaro menu that lets me choose the kernel or memory test, but once I choose the kernel it gives me an error…

“error attempt to read or write outside of disk ‘hd0’” and after a few seconds I get dumped to “emergency shell” which as far as I can tell is totally useless.

Hi @pjbrunet :wink:

Here are more superblocks try:

sudo dumpe2fs /dev/sdxY | grep -i superblock

then try:

e2fsck -f -b <superblock_number> /dev/sdxY

or you can try mount it with a special superblock:

sudo mount -o sb=<superblock_number> /dev/sdxY /mnt/sdxY

Good luck!

PS: Next time i would suggest to use f2fs for flash drives: F2FS - ArchWiki

e2fsck -f -b 0 /dev/sdc1
e2fsck 1.45.6 (20-Mar-2020)
e2fsck: Read-only file system while trying to open /dev/sdc1
Disk write-protected; use the -n option to do a read-only
check of the device.

Keep sure the usb drive is not mounted.

findmnt /dev/sdc1

What you also should consider are badblock: badblocks - ArchWiki

it’s not mounted.

Using USB sticks works fine.

The problem occurs over time - if you have not taken measures - that USB sticks get’s worn and then suddenly - poof.

Using another linux system to run filesystem check on the device’s partitions - may be helpful - otherwise reinstall the stick.

USB sticks die eventually. I have had 3 as boot drives for my FreeNAS. FreeNAS is really good about minimizing writes to the boot device if it knows its flash storage. The USB sticks did not get warm, got little in terms of read/write, but were up 24/7 for about 2 to 3 years before they died anyway.

Maybe you can still recover something from the drive, maybe you can even reformat it, but I would not trust it for anything worthwhile anymore.

Fwiw, the USB sticks that died in my FreeNAS were completely unrecoverable. On the flipside, I have some USB sticks that mostly sit in a drawer and that I only use occasionally that are already well into the second decade of their life :slight_smile:

Is there some definitive way to know the USB is really toast?

In my experience: it won’t mount properly, it won’t reformat properly, or it appears to reformat but then doesn’t mount anyway. There may be tools out there to check, but just like with a harddisk that is giving you (intermittent) issues, I’d be very wary of using it for something worthwhile. Even a new brandname USB3 stick is not that expensive :slight_smile:

Yeah, these SanDisk Fits get REALLY hot. I’m thinking it probably burned itself out, literally. I would not buy again. I think you are right, I CONCEDE it’s BROKE. I can’t even format the thing because it won’t mount because of the “read only” error.

Maybe I need to research F2FS like @megavolt said.

Hey,

If you still want to go USB stick way, you can try Corsair Voyager GTX USB 3.1 starting with 128 GB size. There are bigger models too :wink:

On the flip side, you going SSD price range with such USB drive.

I use one of those to boot my Pi4 and it cope well with the temperature. I had temperature issues with other USB sticks that were aluminium made (looking at you transcend!) that were overheating and eventually my Pi4 goes to a halt.

Apologies for this shameless plug.

1 Like

I also use Transcend for that and have had good results. They feel really hot but that’s because the metal case is dissipating the heat. The chip should be running cooler than it would in a plastic case.

1 Like

Well, I’ve had success so far with the Samsung Fit’s… supposedly it has a 5 year warranty. But I’ll definitely check out these recommendations if one of my Samsung Fits die.