I Hit Shutdown whilst kernel installation

Hello there

Yesterday I started updates via the GUI(I’m running gnome). But I’ve forgotten to wait till it is finished and then shutdown the computer. So when I tried to boot my computer this morning the following message appeard:

error file `boot/initramfs-s5.15-x86_64.img` not found

Press any key to continue

When I press any key (besides CTRL + ALT + DEL, which reboots) or wait long enough I get the following message (truncated):

TSC_DEADLINE disabled due to Errata: please updat
microcode to version: 0x22 (or later)

I tried the recovery kernel and older kernels. Some have a bit other error messages, but the behaviour is the same.

a quit old kernel: 5.9.16-1 wokrs and I can boot it normaly, but it falls in to emergency mode. So I tried to look around and found the following: The last three lines of /var/log/pacman.logare:

[ALPM-SCRIPTLET]  ->Running build hook: [filesystem]
[ALPM-SCRIPTLET] ==> Generating module dependencies
[ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/inittramfs-5.10-x86_64.img

I tried to fix that with pacman -Syu, which responds that it can’t lock the database.
Removing that lock, solves that problem but just errors out, because there is no network.

So I run pacman -Qk and it gave me some warnings.

I suspect, that if there is a way to continue the installation/restart I will be fine. Do you have any idea, how I can do that?
Or other ideas how I can fix that problem?

Okey, I found pacman/Restore local database - ArchWiki and used pacman -Suand it prints the following output:

::Starting a full systemupgrade
Nothing to do

(Please note, that I translated it from German to English)

Then you must use the Manjaro USB stick and install the kernel 5.15 again.

1 Like

Then I’ve to create a new USB stick…

How is the best way to install the kernel again from the usb-stick?

chroot into the system from live USB.

Use MHWD tool to install kernel from chrooted terminal/system.


1 Like

you boot on USB live manjaro ,
you go in chroot , remove EOL kernels and only keep
version 5.10 LTS , 5.15LTS , 5.18 or 5.19
( to remove option -r )

sudo manjaro-chroot -a
mhwd-kernel -li
mhwd-kernel -r linux59 ( and also do for older ones )
mkinitcpio -P
exit ( end-chroot )

Hello @stephane ,@omano, @Keruskerfuerst

Thank you for your information, with that I was able to uninstall old kernels and fix everything. Now my system is up and running again. (On 5.15)

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.