I haven't managed to make KDE Connect work

I have never succeded in using kdeconnect - in fact - I have completely giving up any attemp.


I know my comment was kind’o off-topic - I meant rethorical - but nonetheless the comments to my rethorical comment which then got split off → sparked a renewed interest in verifiying why I was not able to make it work - thus this thread has grown.

No idea why you haven’t succeeded…
It just needs BlueTooth enabled on both devices to be able to pair eachother in the Android-app :woman_shrugging:

That may explain why - my desktop doesn’t have bluetooth - perhaps I should try the BT adapter I have

I don’t have Bluetooth either, i use Internet (cabled on desktop, Wifi on phone).


Now I am confused - I tried everything - I could connect but that was all - my primary use case would have been sms - which is why I gave in.

Do you mean, as having the desktop and phone see each other?
If you at least got to that, you may have yet to configure which features to enable on both ends.

Or the same “Wifi”

I think a BT adapter has something to do with it - at least in my case.


No connection to SMS plugin if only paired using network.

If using BT to pair SMS works.

I use KDE Connect app on Android.
It works fine with KDE Plasma Wayland 5.26 and GNOME using GSconnect plugin on my wifi network, not bluetooth.

1 Like

all my androids are working without problems through wifi no bluetooth, i don’t have, just allow…maybe the adapter is shared or wifi or bluetooth in your case

No bluetooth on my desktop and kdeconnect works. Have you opened up the necessary ports in your firewall?


Unnecessary. Wifi on android device within the same network as manjaro machine works for me.

No, it doesn’t. You’re just confusing the poor man.

In fact, BlueTooth support was requested but never implemented as far as I remember.

“Ayuh.” :point_up:

– Jud Crandall

1 Like

I am a seasoned system administrator so I like to think I know my way around network, firewall, routing, dhcp, dns, network file systems, samba - you name it - kdeconnect and sms is a nice to have - but is not a necessity or requiment - I can live without.

I have been revisting kdeconnect many times - always Android devices - last time was a couple of moons.

My primary phone until a week ago

  • Huawei POT-LX1
    • I could pair the devices - initiaing pair from one or the other
    • setting permissions on phone
    • loading texts was always hung

I swapped the Huawei for Galaxy A53 2022-11-17T23:00:00Z

Triggered by the comments by my fellow members I decided to give it try using a BT adapter

  • adding a BT adapter to my destkop
  • systemctl start bluetooth
  • pair from computer → success
  • settting permissions on phone
  • texts load

One more test

  • systemctl stop bluetooth
  • pair from computer → success
  • no texts loading

I decided to postpone further playing - I was watching Dune movie

  • removed kdeconnect
  • removed ~/.config/kdeconnect
  • shutdown and went to bed

This morning - checking in on the forum - read the comments here - I dediced to give it another shot

  • reinstalled kdeconnect - (no bluetooth)
  • initate pairing from the phone (previously I had used desktop to initiate)
  • surprise - texts is now loading

I have no clue


KdeConnect is 22.08.3-1 which was released Thursday, 3 November 2022

Operating System: Manjaro Linux
KDE Plasma Version: 5.26.3
KDE Frameworks Version: 5.100.0
Qt Version: 5.15.7
Kernel Version: 6.1.0-1-MANJARO (64-bit)
Graphics Platform: Wayland

I gave it a try, but as I don’t use SMS (I don’t even receive SMS), I don’t actually have a use case for it.

I don’t use it much either - but I do get texts - that someone expect a reply to - which is far easier using my workstation than my clumsy fingers on a tiny keyboard and a spellchecker which like to change my words without warning - only to realize the change after the message has been sent.


@freggel.doe @Yochanan @linux-aarhus et all,
I’m glad it also works without BT, i just mentioned what i used when i paired mine :woman_shrugging:
But the bottom line was that it wasn’t that hard to get it to work :wink:

It could be a requirement of Android OS to make the initial pairing work, outside the app :woman_shrugging:

Anyhow it now works for @linux-aarhus and that’s what matters :+1: