I have to press Alt + Shift twice for switching keyboard layout

Hello everyone! I’m currently using Manjaro Gnome (latest version) in my Huawei Mate Pro laptop. I have set two keyboard layouts: English and Greek. I’ve also setup the shortcuts for Alt + Shift, but when I’m trying to switch in Greek, I have to press twice the Alt + Shift.

Example: Pressing Alt + Shift will switch from English to Greek. Then pressing again will switch to English. Then pressing again won’t switch to Greek but to English again. Third time will make the change. It’s like having 3 language layouts, 2 in English and 1 in Greek. I’ve checked the settings and everything seems to be okay and I can’t find a second English layout, but only the 2 I’ve chosen.

Any ideas on how to fix the problem? It’s driving me crazy when writing long posts.

Thanks in advance!

Hello!

How did you set up the shortcuts for alt+shift? Personally, I only use gnome tweaks for this setting. Have you edited a file manually?

Hi, I’ve had the same problem! Solved it this way:

But you should set: <Alt>Shift_L

1 Like