I have been trying for 3 days still can't figure out how to install manjaro xfce please . Whenever I install it says no bootable device found

No bootable device found (I don’t know the other 40 character imma write anything usidhsbwidixbdbdjdjdhdbdiwisbsbdhhfwtnnegneydgtefwjfitgwjgjwffjggekykgkeyejegnfengjdvkgskgdkdkrhkgkgskshkyrkyelykgjegk) sry

It would be more helpful if you included more information.
Such as … which ISO exactly and where did you get it? Link?
How did you prepare the ISO? Written to USB? With what tool? Did you verify the integrity?
How exactly are you trying to boot the Live ISO?
Have you succesfully identified a way to select boot device or change boot order?
What steps have you taken? On what kind of machine?
And so on…


How do I give image

If you ask Google that same question, you likely get some image sharing platform addresses within the first results.

as to the main problem:
use a few more words to describe your issue - as it is, the description is only clear to you.

Dual-boot Windows or not, check BIOS Settings:

disable secure boot ( if dual boot Windows)
disable fast boot (If dual boot Windows)
no CSM
all disks on AHCI

If dual-boot, both installed likewise e.g if Windows is UEFI install, Manjaro should be as well.

you don’t - this is a text based chat not facebook or similiar - this forum breaks if overloaded with images - and we like to keep the text.

Change your firmware settings

  • Ensure you have disabled CSM (BIOS or Legacy boot options)
  • Only EFI should be available
  • Ensure your disable any raid settings in firmware
  • Only AHCI should be used

Could be that the boot device (internal HDD or, more likely, SSD) needs a bit of time to come up, but the BIOS has already decided “there is nothing to boot off” when it is finally ready.

See if your BIOS has an option to set a delay, start with a large value, say, 20 seconds, and if that works decrease the time just before booting becomes unreliable.

Has worked on my other machine running Kubuntu.

EDIT: Or did you mean the installation device? Is USB boot enabled in BIOS?


I’m sorry, Google Translate simply wouldn’t translate that.

1 Like

I don’t want dual boot. I disable secure boot but can’t find csm

I use unetbootein

don’t - use etcher or ventoy - plain old command line dd

I have a dvd-rw but I can’t format it

Don’t use DVD - use USB - DVD is too slow when it comes to loading 4GB from optical medium

I have a card reader of 16gb. Can I use it?

Probably not - booting from sdcard is usually not an option - unless it is a SoC like raspberry pi - in such case the x86_64 doesn’t cut it.

Find a 8GB USB stick

Ok I will get a USB then . I think it was the only problem.i will tell you after trying. Thanks

Thank you everyone I have installed manjaro but got into driver problem. My keyboard worked in some applications but didnt worked in terminal so I installed drive using manjaro gui. But I got stuck in booy loop now how to fix that

Once again theres virtually no information for this ‘new issue’.

I’m not sure I understand this. You installed a driver for your keyboard?

I dont know what this is. If ‘boot loop’, I still dont know much because theres no information.

Sorry but “I installed a drive, now booy loop” … even if translated to something more sensible … cant really be answered.

1 Like