I have 2 AMD PCs with exact same software but only one can mine Ethereum


I have first posted this on Reddit but I couldn’t have and responds, so I wanted to try here. I hope, I picked the correct category.

I have two PCs like these;

  1. Intel 5 6500 with 8GB DDR4 RAM and a Radeon 5700XT
  2. AMD 7 3800X with 16GB DDR4 RAM and a Radeon 6700XT.

Couple days ago I have ınstalled Manjaro KDE on both of them. Then:

  • I updated both systems with Add/Remove software

  • used AUR to install 8192EU-DKMS driver for TP link USB Wi-Fi dongles

  • updated the kernel to 5.16.5

  • used AUR to install opencl-amd package

  • downloaded teamredminer zip archive

This is where the similarities end. The one with 5700XT starts mining immediately and has no problems. Actually, it was mining this way for months I just wanted to “exercise” on my Linux installing skills for the weekend. And it still works without any problem.

The one with 6700XT, on the other hand, simply can not mine. It throws an:

  "Failed to list OpenCL devices for platform 0."

error in the miner. I searched the error online and tried every solution I have found. I also have looked for other solutions like installing/uninstalling packages opencl-mesa, rocm-opencl, amdvlk, amdvlk 32bit, ocl-icd, 32 bit ocl-icd, clinfo and some combinations etc. but none worked. In one forum I have seen “clinfo” and apperantly it tells the story why it does or does not work. It didn’t work in the beginning but then I figured it could have been installed and found it in the Add/Remove Software easily (I’m beginning to understand how things are done in the Linux world :slight_smile: ) The outcome is like this:

"Number of platforms                               2 
  Platform Name                                   AMD Accelerated Parallel Processing 
  Platform Vendor                                 Advanced Micro Devices, Inc. 
  Platform Version                                OpenCL 2.2 AMD-APP (3361.0) 
  Platform Profile                                FULL_PROFILE 
  Platform Extensions                             cl_khr_icd cl_amd_event_callback  
  Platform Extensions function suffix             AMD 
  Platform Host timer resolution                  1ns 
 Platform Name                                   Clover 
  Platform Vendor                                 Mesa 
  Platform Version                                OpenCL 1.1 Mesa 21.3.5 
  Platform Profile                                FULL_PROFILE 
  Platform Extensions                             cl_khr_icd 
  Platform Extensions function suffix             MESA 
 Platform Name                                   AMD Accelerated Parallel Processing 
Number of devices                                 0 
 Platform Name                                   Clover 
Number of devices                                 1 
  Device Name                                     AMD Radeon RX 6700 XT (NAVY_FLOUNDER, DRM 3.44.0, 5.16.5-1-MANJARO, LLVM 13.0.0) 
  Device Vendor                                   AMD 
  Device Vendor ID                                0x1002 
  Device Version                                  OpenCL 1.1 Mesa 21.3.5 
  Device Numeric Version                          0x401000 (1.1.0) 
  Driver Version                                  21.3.5 
  Device OpenCL C Version                         OpenCL C 1.1  
  Device Type                                     GPU 
  Device Profile                                  FULL_PROFILE 
  Device Available                                Yes 
  Compiler Available                              Yes 
  Max compute units                               40 
  Max clock frequency                             2855MHz 
  Max work item dimensions                        3 
  Max work item sizes                             256x256x256 
  Max work group size                             256 
fatal error: cannot open file '/usr/share/clc/gfx1030-amdgcn-mesa-mesa3d.bc': No such file or directory 
  Preferred work group size multiple (kernel)     <getWGsizes:1504: create kernel : error -46> 
  Preferred / native vector sizes                  
    char                                                16 / 16       
    short                                                8 / 8        
    int                                                  4 / 4        
    long                                                 2 / 2        
    half                                                 0 / 0        (n/a) 
    float                                                4 / 4        
    double                                               2 / 2        (cl_khr_fp64) 
  Half-precision Floating-point support           (n/a) 
  Single-precision Floating-point support         (core) 
    Denormals                                     No 
    Infinity and NANs                             Yes 
    Round to nearest                              Yes 
    Round to zero                                 No 
    Round to infinity                             No 
    IEEE754-2008 fused multiply-add               No 
    Support is emulated in software               No 
    Correctly-rounded divide and sqrt operations  No 
  Double-precision Floating-point support         (cl_khr_fp64) 
    Denormals                                     Yes 
    Infinity and NANs                             Yes 
    Round to nearest                              Yes 
    Round to zero                                 Yes 
    Round to infinity                             Yes 
    IEEE754-2008 fused multiply-add               Yes 
    Support is emulated in software               No 
  Address bits                                    64, Little-Endian 
  Global memory size                              12884901888 (12GiB) 
  Error Correction support                        No 
  Max memory allocation                           10307921510 (9.6GiB) 
  Unified memory for Host and Device              No 
  Minimum alignment for any data type             128 bytes 
  Alignment of base address                       32768 bits (4096 bytes) 
  Global Memory cache type                        None 
  Image support                                   No 
  Local memory type                               Local 
  Local memory size                               32768 (32KiB) 
  Max number of constant args                     16 
  Max constant buffer size                        67108864 (64MiB) 
  Max size of kernel argument                     1024 
  Queue properties                                 
    Out-of-order execution                        No 
    Profiling                                     Yes 
  Profiling timer resolution                      0ns 
  Execution capabilities                           
    Run OpenCL kernels                            Yes 
    Run native kernels                            No 
    ILs with version                              (n/a) 
  Built-in kernels with version                   (n/a) 
  Device Extensions                               cl_khr_byte_addressable_store cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_int64_base_atomics cl_khr_int64_extended_atomics cl_khr_fp64 cl_khr_extended_vers
  Device Extensions with Version                  cl_khr_byte_addressable_store                                    0x400000 (1.0.0) 
                                                  cl_khr_global_int32_base_atomics                                 0x400000 (1.0.0) 
                                                  cl_khr_global_int32_extended_atomics                             0x400000 (1.0.0) 
                                                  cl_khr_local_int32_base_atomics                                  0x400000 (1.0.0) 
                                                  cl_khr_local_int32_extended_atomics                              0x400000 (1.0.0) 
                                                  cl_khr_int64_base_atomics                                        0x400000 (1.0.0) 
                                                  cl_khr_int64_extended_atomics                                    0x400000 (1.0.0) 
                                                  cl_khr_fp64                                                      0x400000 (1.0.0) 
                                                  cl_khr_extended_versioning                                       0x400000 (1.0.0) 
NULL platform behavior 
  clGetPlatformInfo(NULL, CL_PLATFORM_NAME, ...)  No platform 
  clGetDeviceIDs(NULL, CL_DEVICE_TYPE_ALL, ...)   No platform 
  clCreateContext(NULL, ...) [default]            No platform 
  clCreateContext(NULL, ...) [other]              Success [MESA] 
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_DEFAULT)  No devices found in platform 
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_CPU)  No devices found in platform 
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_GPU)  No devices found in platform 
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_ACCELERATOR)  No devices found in platform 
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_CUSTOM)  No devices found in platform 
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_ALL)  No devices found in platform

BTW, games (with Wine and Steam Proton) work perfectly so I don’t think the GPU is the problem here. There is also a Windows partition and mining works for it, too.

Since every result I found in online searches failed, as a last resort I wanted to ask you people. Would you please help me like I am super new to Linux? I have been using Linux for a very long time but my experience is limited to what comes preinstalled with Ubuntu family mostly (Office, web browsing, Thunderbird, Blender, etc.). Playing games, Installing and configuring things, mining, using terminal and more tech advanced applications are all new to me.

Thanks for reading this far:)

In case anyone has the same problem, the solution is to install opencl-amd package version 20.40. Any newer package than this will fail to utilize Radon 6000 series for opencl operations.

Did you try the latest opencl-amd package? At least two people have reported that it works with 6000 series. (It was released on Friday)

It is not shown in Add/Remove software updates (AUR is enabled)? I know 21.50 has been released for Arch but Manjaro shows 21.40.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.