I get this error on 6.3 sometimes

I get this error on 6.3 sometimes:

[7.8329751] FAT-fs (nvme@n1p1): bogus number of reserved sectors
[FAILED] Failed to mount /boot/efi
2 See
'systemctl status boot-efi.mount' for details.
[DEPEND] Dependency failed for Local File Systems.

fsck give me 3 options:

sudo fsck.vfat /dev/nvme0n1p1
fsck.fat 4.2 (2021-01-31)
There are differences between boot sector and its backup.
This is mostly harmless. Differences: (offset:original/backup)
1) Copy original to backup
2) Copy backup to original
3) No action

Chosen Option 2 saved changes and rebooted seems solved.


I just recently switched to 6.3 and my boot could not be detected after a bios update.
Reinstallation of grub fixed it.

Ran 6.1 LTS before and did multiple bios updates without that ever happening.

Never seen that behavior though (the options when booting like above) but have only been using 6.3 for about a week.

Using dual boot with windows.
Windows boot was still discoverable.

Could this be related?

I do not have dual boot on a single drive.

I use 2 ssd‘s one for Linux, one for Windows

I use same disk, but 2 partitions ofc.
But you DO have dual boot.
More interesting, maybe… xD

What? The kernel? No.
The thing that messed up your boot was the BIOS change/update.

1 Like

I also reverted it back by cloning my second bios, so the bios reverted back to how it exactly was before the bios update.

I’m probably going to remove my 6.3 and revert to the LTS and see if the behavior is the same, I still have a newer bios I want to try.

Could ofc be completely random that it just happened to happen the first time ever while doing the changes and then reverting.

What error? Please edit your post to include it. Photos / Screenshots don’t count.

Note that I’ve again moved your random post from an Announcements post to a new topic. You were using the unstable branch, now you’re using stable?

Since there are features on proprietary smartphones like text recognition I am able to copy and paste text from images…

I thought it was an issue which introduced by the latest stable update. But you are right if I have some issue later I will post a separate thread.

And it’s solved by my self. :wink:

My Profile is tagged with stable I am using it on my host system.
On some VMs and Older Hardware I using testing or unstable :wink:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.