I followed the tutorial, but still can't enable Wayland with Nvidia in Gnome

Hi there!

I tried to follow the [Howto] Use wayland with propietary nvidia drivers tutorial. The only step I couldn’t finish was number 3:
gsettings set org.gnome.mutter experimental-features [\"kms-modifiers\"]
after which I get:
zsh: no matches found: ["kms-modifiers"]

After making the changes described in the tutorial, I did not get a 3rd option in GDM’s cog. What is more, two strange behaviors have just appeared:
1- I don’t see the GRUB menu any longer
2- During 2 out of the 4 reboots I have tried so far, after entering my password in GDM and pressing Enter, the screen freezes and I need to reboot using the PC’s power button

Inxi reports:

System:
  Kernel: 5.10.61-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=20705b87-eec6-4fb3-8353-031c51df1cac ro quiet splash apparmor=1 
  security=apparmor udev.log_priority=3 nvidia-drm.modeset=1 
  Desktop: GNOME 40.4 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1 
  Distro: Manjaro Linux base: Arch Linux 
Machine:
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX X570-E GAMING v: Rev X.0x 
  serial: <filter> UEFI: American Megatrends v: 3405 date: 02/01/2021 
Battery:
  Device-1: hid-b8:09:8a:ed:37:f6-battery model: Alan E Cyment’s Keyboard 
  serial: N/A charge: N/A status: Discharging 
  Device-2: hidpp_battery_0 model: Logitech Wireless Touch Keyboard K400 Plus 
  serial: <filter> charge: 100% (should be ignored) rechargeable: yes 
  status: Discharging 
Memory:
  RAM: total: 15.6 GiB used: 2.4 GiB (15.4%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Info: 12-Core model: AMD Ryzen 9 5900X bits: 64 type: MT MCP arch: Zen 3 
  family: 19 (25) model-id: 21 (33) stepping: 0 microcode: A201009 cache: 
  L2: 6 MiB bogomips: 177651 
  Speed: 2799 MHz min/max: 2200/3700 MHz boost: enabled Core speeds (MHz): 
  1: 2799 2: 2239 3: 2217 4: 2217 5: 2794 6: 2246 7: 2235 8: 2236 9: 2235 
  10: 2237 11: 2219 12: 2691 13: 2237 14: 2235 15: 2219 16: 2216 17: 2216 
  18: 2240 19: 2239 20: 2242 21: 2215 22: 2508 23: 2218 24: 2218 
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 
  bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy 
  constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total cqm_occup_llc 
  cr8_legacy cx16 cx8 de decodeassists erms extapic extd_apicid f16c 
  flushbyasid fma fpu fsgsbase fsrm fxsr fxsr_opt ht hw_pstate ibpb ibrs ibs 
  invpcid irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor 
  movbe msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx ospke osvw 
  overflow_recov pae pat pausefilter pclmulqdq pdpe1gb perfctr_core 
  perfctr_llc perfctr_nb pfthreshold pge pku pni popcnt pse pse36 rdpid rdpru 
  rdrand rdseed rdt_a rdtscp rep_good sep sha_ni skinit smap smca smep ssbd 
  sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce 
  topoext tsc tsc_scale umip v_vmsave_vmload vaes vgif vmcb_clean vme vmmcall 
  vpclmulqdq wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, 
  STIBP: always-on, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Nanjing Magewell Eco Capture Dual HDMI M.2 vendor: SafeNet 
  driver: N/A bus-ID: 04:00.0 chip-ID: 1cd7:0051 class-ID: 0400 
  Device-2: NVIDIA TU116 [GeForce GTX 1660 Ti] vendor: Micro-Star MSI 
  driver: nvidia v: 470.63.01 alternate: nouveau,nvidia_drm bus-ID: 0b:00.0 
  chip-ID: 10de:2182 class-ID: 0300 
  Display: x11 server: X.Org 1.20.13 compositor: gnome-shell driver: 
  loaded: nvidia display-ID: :1 screens: 1 
  Screen-1: 0 s-res: 5440x1080 s-dpi: 96 s-size: 1439x286mm (56.7x11.3") 
  s-diag: 1467mm (57.8") 
  Monitor-1: DP-0 res: 1920x1080 hz: 60 dpi: 93 size: 527x296mm (20.7x11.7") 
  diag: 604mm (23.8") 
  Monitor-2: DP-2 res: 1920x1080 hz: 60 
  Monitor-3: DP-4 res: 1600x900 hz: 60 dpi: 92 size: 443x249mm (17.4x9.8") 
  diag: 508mm (20") 
  OpenGL: renderer: NVIDIA GeForce GTX 1660 Ti/PCIe/SSE2 
  v: 4.6.0 NVIDIA 470.63.01 direct render: Yes 
Audio:
  Device-1: Nanjing Magewell Eco Capture Dual HDMI M.2 vendor: SafeNet 
  driver: N/A bus-ID: 04:00.0 chip-ID: 1cd7:0051 class-ID: 0400 
  Device-2: NVIDIA TU116 High Definition Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus-ID: 0b:00.1 chip-ID: 10de:1aeb 
  class-ID: 0403 
  Device-3: AMD Starship/Matisse HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus-ID: 0d:00.4 chip-ID: 1022:1487 
  class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.61-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.34 running: no 
Network:
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 05:00.0 
  chip-ID: 8086:2723 class-ID: 0280 
  IF: wlp5s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel 
  port: e000 bus-ID: 06:00.0 chip-ID: 10ec:8125 class-ID: 0200 
  IF: enp6s0 state: down mac: <filter> 
  Device-3: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel 
  port: d000 bus-ID: 07:00.0 chip-ID: 8086:1539 class-ID: 0200 
  IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: noprefixroute scope: global broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  IF-ID-1: br-ac907f97584b state: down mac: <filter> 
  IP v4: <filter> scope: global broadcast: <filter> 
  IF-ID-2: docker0 state: down mac: <filter> 
  IP v4: <filter> scope: global broadcast: <filter> 
  WAN IP: <filter> 
Bluetooth:
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-6:3 
  chip-ID: 8087:0029 class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends 
Logical:
  Message: No logical block device data found. 
RAID:
  Message: No RAID data found. 
Drives:
  Local Storage: total: 494.58 GiB used: 421.25 GiB (85.2%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Corsair model: Force MP600 
  size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s 
  lanes: 4 type: SSD serial: <filter> rev: EGFM13.0 temp: 37.9 C scheme: GPT 
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Kingston 
  model: DataTraveler 3.0 size: 28.82 GiB block-size: physical: 512 B 
  logical: 512 B type: N/A serial: <filter> scheme: GPT 
  Message: No optical or floppy data found. 
Partition:
  ID-1: / raw-size: 465.46 GiB size: 457.16 GiB (98.22%) 
  used: 421.25 GiB (92.1%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
  label: N/A uuid: 20705b87-eec6-4fb3-8353-031c51df1cac 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A 
  uuid: 6206-C799 
Swap:
  Alert: No swap data was found. 
Unmounted:
  ID-1: /dev/sda2 maj-min: 8:2 size: 4.9 MiB fs: vfat label: ESP 
  uuid: F940-6C0E 
  ID-2: /dev/sda3 maj-min: 8:3 size: 300 KiB fs: <superuser required> 
  label: N/A uuid: N/A 
USB:
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 6 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 1-5:2 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s 
  power: 100mA chip-ID: 05e3:0610 class-ID: 0900 
  Device-1: 1-6:3 info: Intel AX200 Bluetooth type: Bluetooth driver: btusb 
  interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0029 
  class-ID: e001 
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-4: 3-0:1 info: Full speed (or root) Hub ports: 6 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 3-4:2 info: ASUSTek AURA LED Controller type: HID 
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 16mA 
  chip-ID: 0b05:18f3 class-ID: 0300 serial: <filter> 
  Hub-5: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Device-1: 4-1:2 info: Kingston DataTraveler 100 G3/G4/SE9 G2/50 
  type: Mass Storage driver: usb-storage interfaces: 1 rev: 3.2 speed: 5 Gb/s 
  power: 296mA chip-ID: 0951:1666 class-ID: 0806 serial: <filter> 
  Hub-6: 5-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-7: 6-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-8: 7-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 7-1:2 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID 
  driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s 
  power: 98mA chip-ID: 046d:c52b class-ID: 0300 
  Hub-9: 7-4:3 info: Microchip (formerly SMSC) USB2734 ports: 5 rev: 2.1 
  speed: 480 Mb/s chip-ID: 0424:2734 class-ID: 0900 
  Hub-10: 7-4.2:4 info: Microchip (formerly SMSC) ports: 2 rev: 2.0 
  speed: 480 Mb/s power: 2mA chip-ID: 0424:2412 class-ID: 0900 
  Device-1: 7-4.2.1:6 info: Melfas LGD AIT Touch Controller type: HID 
  driver: hid-generic,hid-multitouch,usbhid interfaces: 2 rev: 2.0 
  speed: 12 Mb/s power: 100mA chip-ID: 1fd2:6103 class-ID: 0300 
  Device-2: 7-4.5:5 info: Microchip (formerly SMSC) Hub Controller type: HID 
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 480 Mb/s 
  chip-ID: 0424:274c class-ID: 0300 
  Hub-11: 8-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 
  speed: 10 Gb/s chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-12: 8-4:2 info: Microchip (formerly SMSC) USB5734 ports: 4 rev: 3.1 
  speed: 5 Gb/s chip-ID: 0424:5734 class-ID: 0900 
Sensors:
  System Temperatures: cpu: 41.9 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 481 Uptime: 2m wakeups: 3 Init: systemd v: 249 tool: systemctl 
  Compilers: gcc: 11.1.0 Packages: 1711 apt: 0 pacman: 1700 lib: 439 
  flatpak: 5 snap: 6 Shell: Zsh v: 5.8 running-in: gnome-terminal inxi: 3.3.06

xrandr:

Screen 0: minimum 8 x 8, current 5440 x 1080, maximum 32767 x 32767
DP-0 connected 1920x1080+3520+0 (normal left inverted right x axis y axis) 527mm x 296mm
   1920x1080     60.00*+  59.94    50.00  
   1600x900      60.00  
   1280x1024     75.02    60.02  
   1280x800      59.81  
   1280x720      60.00    59.94    50.00  
   1152x864      75.00  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    59.94    59.93  
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 connected 1920x1080+1600+0 normal X axis (normal left inverted right x axis y axis) 294mm x 166mm
   1920x1080     60.02*+  60.00  
   1600x900      60.00  
   1280x1024     60.02  
   1152x864      59.96  
   1024x768      60.00  
   800x600       60.32  
   640x480       59.94  
DP-3 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
DP-4 connected primary 1600x900+0+0 (normal left inverted right x axis y axis) 443mm x 249mm
   1600x900      60.00*+
   1440x900      59.89  
   1280x1024     60.02  
   1280x800      59.81  
   1280x720      60.00  
   1024x768      60.00  
   800x600       60.32  
   640x480       59.94  
DP-5 disconnected (normal left inverted right x axis y axis)

sudo dmesg | grep nvidia


[    0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 root=UUID=20705b87-eec6-4fb3-8353-031c51df1cac ro quiet splash apparmor=1 security=apparmor udev.log_priority=3 nvidia-drm.modeset=1
[    0.053903] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 root=UUID=20705b87-eec6-4fb3-8353-031c51df1cac ro quiet splash apparmor=1 security=apparmor udev.log_priority=3 nvidia-drm.modeset=1
[    0.942169] nvidia: loading out-of-tree module taints kernel.
[    0.942173] nvidia: module license 'NVIDIA' taints kernel.
[    0.950460] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[    0.957573] nvidia-nvlink: Nvlink Core is being initialized, major device number 236
[    0.957833] nvidia 0000:0b:00.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=none:owns=none
[    1.009937] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  470.63.01  Tue Aug  3 20:30:55 UTC 2021
[    1.010474] [drm] [nvidia-drm] [GPU ID 0x00000b00] Loading driver
[    2.083784] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:0b:00.0 on minor 0
[    2.100629] nvidia_uvm: module uses symbols from proprietary module nvidia, inheriting taint.
[    2.106480] nvidia-uvm: Loaded the UVM driver, major device number 234.
[    2.911036] nvidia-gpu 0000:0b:00.3: enabling device (0000 -> 0002)
[    4.563161] nvidia-gpu 0000:0b:00.3: i2c timeout error e0000000
journalctl --catalog --priority=3 --boot=-1

Sep 05 22:50:59 pc-laburo kernel: __common_interrupt: 1.55 No irq handler for vector
Sep 05 22:50:59 pc-laburo kernel: __common_interrupt: 2.55 No irq handler for vector
Sep 05 22:50:59 pc-laburo kernel: __common_interrupt: 3.55 No irq handler for vector
Sep 05 22:50:59 pc-laburo kernel: __common_interrupt: 4.55 No irq handler for vector
Sep 05 22:50:59 pc-laburo kernel: __common_interrupt: 5.55 No irq handler for vector
Sep 05 22:50:59 pc-laburo kernel: __common_interrupt: 6.55 No irq handler for vector
Sep 05 22:50:59 pc-laburo kernel: __common_interrupt: 7.55 No irq handler for vector
Sep 05 22:50:59 pc-laburo kernel: __common_interrupt: 8.55 No irq handler for vector
Sep 05 22:50:59 pc-laburo kernel: __common_interrupt: 9.55 No irq handler for vector
Sep 05 22:50:59 pc-laburo kernel: __common_interrupt: 10.55 No irq handler for vector
Sep 05 22:50:59 pc-laburo kernel: 
Sep 05 22:50:59 pc-laburo systemd-udevd[448]: vboxdrv: /usr/lib/udev/rules.d/60-vboxdrv.rules:1 Only network interfaces can be renamed, ignoring NAME="vboxdrv".
Sep 05 22:50:59 pc-laburo systemd-udevd[461]: vboxdrvu: /usr/lib/udev/rules.d/60-vboxdrv.rules:2 Only network interfaces can be renamed, ignoring NAME="vboxdrvu".
Sep 05 22:50:59 pc-laburo kernel: sp5100-tco sp5100-tco: Watchdog hardware is disabled
Sep 05 22:51:00 pc-laburo systemd-udevd[507]: vboxdrv: /usr/lib/udev/rules.d/60-vboxdrv.rules:1 Only network interfaces can be renamed, ignoring NAME="vboxdrv".
Sep 05 22:51:00 pc-laburo systemd-udevd[481]: vboxdrvu: /usr/lib/udev/rules.d/60-vboxdrv.rules:2 Only network interfaces can be renamed, ignoring NAME="vboxdrvu".
Sep 05 22:51:00 pc-laburo systemd-udevd[499]: vboxnetctl: /usr/lib/udev/rules.d/60-vboxdrv.rules:3 Only network interfaces can be renamed, ignoring NAME="vboxnetctl".
Sep 05 22:51:00 pc-laburo gnome-session-binary[1192]: Unrecoverable failure in required component org.gnome.Shell.desktop
Sep 05 22:51:00 pc-laburo gdm-launch-environment][1097]: GLib-GObject: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Sep 05 22:51:01 pc-laburo gdm-launch-environment][1232]: GLib-GObject: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Sep 05 22:51:01 pc-laburo gdm-launch-environment][1280]: GLib-GObject: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Sep 05 22:51:01 pc-laburo kernel: nvidia-gpu 0000:0b:00.3: i2c timeout error e0000000
Sep 05 22:51:01 pc-laburo kernel: ucsi_ccg 5-0008: i2c_transfer failed -110
Sep 05 22:51:01 pc-laburo kernel: ucsi_ccg 5-0008: ucsi_ccg_init failed - -110
Sep 05 22:51:02 pc-laburo kernel: [drm:nv_drm_connector_get_modes [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to get mode at modeIndex 13 of NvKmsKapiDisplay 0x00000100
Sep 05 22:51:02 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x00000006
Sep 05 22:51:02 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x00000007
Sep 05 22:51:02 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x00000008
Sep 05 22:51:02 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x00000009
Sep 05 22:51:02 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x0000000a
Sep 05 22:51:02 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x0000000b
Sep 05 22:51:03 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x00000006
Sep 05 22:51:03 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x00000007
Sep 05 22:51:03 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x00000008
Sep 05 22:51:03 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x00000009
Sep 05 22:51:03 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x0000000a
Sep 05 22:51:03 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x0000000b
Sep 05 22:51:04 pc-laburo bluetoothd[1333]: src/service.c:btd_service_connect() a2dp-sink profile connect failed for 1C:52:16:9C:FE:42: Protocol not available
Sep 05 22:51:04 pc-laburo bluetoothd[1333]: profiles/input/device.c:ioctl_is_connected() Can't get HIDP connection info
Sep 05 22:51:04 pc-laburo bluetoothd[1333]: profiles/input/device.c:ioctl_is_connected() Can't get HIDP connection info

The main reason for trying to use Wayland is having better trackpad support.

Would you need more information to try and diagnose what the problem is?

Thanks in advance for your help,
Alan

I guess you run into a bug, have a look here: https://bugzilla.kernel.org/show_bug.cgi?id=206653

Possible workaround is just blacklist this module: i2c_nvidia_gpu.

No idea what it does exactly, but somehow it handles the USB Type C outputs: https://bugzilla.kernel.org/show_bug.cgi?id=206653#c12

Hi!

Thanks for your quick reply. I followed your advice, but the 3 problems persist:

1- No GRUB menu
2- System hangs more than half the times I enter my password in GDM
3- Only 2 options in GDM cog (i.e. No Wayland alternative)

Here are some updated logs:

sudo dmesg | grep nvidia

[    0.053960] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 root=UUID=20705b87-eec6-4fb3-8353-031c51df1cac ro quiet splash apparmor=1 security=apparmor udev.log_priority=3 nvidia-drm.modeset=1
[    0.941091] nvidia: loading out-of-tree module taints kernel.
[    0.941096] nvidia: module license 'NVIDIA' taints kernel.
[    0.949471] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[    0.956789] nvidia-nvlink: Nvlink Core is being initialized, major device number 236
[    0.957055] nvidia 0000:0b:00.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=none:owns=none
[    1.002961] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  470.63.01  Tue Aug  3 20:30:55 UTC 2021
[    1.003459] [drm] [nvidia-drm] [GPU ID 0x00000b00] Loading driver
[    2.074420] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:0b:00.0 on minor 0
[    2.090379] nvidia_uvm: module uses symbols from proprietary module nvidia, inheriting taint.
[    2.095447] nvidia-uvm: Loaded the UVM driver, major device number 234.

journalctl --catalog --priority=3 --boot=-1

Sep 06 09:20:54 pc-laburo kernel: __common_interrupt: 1.55 No irq handler for vector
Sep 06 09:20:54 pc-laburo kernel: __common_interrupt: 2.55 No irq handler for vector
Sep 06 09:20:54 pc-laburo kernel: __common_interrupt: 3.55 No irq handler for vector
Sep 06 09:20:54 pc-laburo kernel: __common_interrupt: 4.55 No irq handler for vector
Sep 06 09:20:54 pc-laburo kernel: __common_interrupt: 5.55 No irq handler for vector
Sep 06 09:20:54 pc-laburo kernel: __common_interrupt: 6.55 No irq handler for vector
Sep 06 09:20:54 pc-laburo kernel: __common_interrupt: 7.55 No irq handler for vector
Sep 06 09:20:54 pc-laburo kernel: __common_interrupt: 8.55 No irq handler for vector
Sep 06 09:20:54 pc-laburo kernel: __common_interrupt: 9.55 No irq handler for vector
Sep 06 09:20:54 pc-laburo kernel: __common_interrupt: 10.55 No irq handler for vector
Sep 06 09:20:54 pc-laburo kernel: 
Sep 06 09:20:54 pc-laburo systemd-udevd[474]: vboxdrvu: /usr/lib/udev/rules.d/60-vboxdrv.rules:2 Only network interfaces can be renamed, ignoring NAME="vboxdrvu".
Sep 06 09:20:54 pc-laburo systemd-udevd[467]: vboxdrv: /usr/lib/udev/rules.d/60-vboxdrv.rules:1 Only network interfaces can be renamed, ignoring NAME="vboxdrv".
Sep 06 09:20:54 pc-laburo systemd-udevd[498]: vboxnetctl: /usr/lib/udev/rules.d/60-vboxdrv.rules:3 Only network interfaces can be renamed, ignoring NAME="vboxnetctl".
Sep 06 09:20:54 pc-laburo kernel: sp5100-tco sp5100-tco: Watchdog hardware is disabled
Sep 06 09:20:55 pc-laburo systemd-udevd[461]: vboxdrv: /usr/lib/udev/rules.d/60-vboxdrv.rules:1 Only network interfaces can be renamed, ignoring NAME="vboxdrv".
Sep 06 09:20:55 pc-laburo systemd-udevd[512]: vboxdrvu: /usr/lib/udev/rules.d/60-vboxdrv.rules:2 Only network interfaces can be renamed, ignoring NAME="vboxdrvu".
Sep 06 09:20:55 pc-laburo gnome-session-binary[1168]: Unrecoverable failure in required component org.gnome.Shell.desktop
Sep 06 09:20:55 pc-laburo gdm-launch-environment][1063]: GLib-GObject: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Sep 06 09:20:56 pc-laburo gdm-launch-environment][1208]: GLib-GObject: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Sep 06 09:20:56 pc-laburo gdm-launch-environment][1255]: GLib-GObject: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Sep 06 09:20:57 pc-laburo kernel: [drm:nv_drm_connector_get_modes [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to get mode at modeIndex 18 of NvKmsKapiDisplay 0x00000100
Sep 06 09:20:57 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x00000006
Sep 06 09:20:57 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x00000007
Sep 06 09:20:57 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x00000008
Sep 06 09:20:57 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x00000009
Sep 06 09:20:57 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x0000000a
Sep 06 09:20:57 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x0000000b
Sep 06 09:20:58 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x00000006
Sep 06 09:20:58 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x00000007
Sep 06 09:20:58 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x00000008
Sep 06 09:20:58 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x00000009
Sep 06 09:20:58 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x0000000a
Sep 06 09:20:58 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x0000000b
Sep 06 09:20:58 pc-laburo kernel: [drm:nv_drm_connector_get_modes [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to get mode at modeIndex 2 of NvKmsKapiDisplay 0x00000100
Sep 06 09:20:58 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x00000006
Sep 06 09:20:58 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x00000007
Sep 06 09:20:58 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x00000008
Sep 06 09:20:58 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x00000009
Sep 06 09:20:58 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x0000000a
Sep 06 09:20:58 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x0000000b
Sep 06 09:20:59 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x00000006
Sep 06 09:20:59 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x00000007
Sep 06 09:20:59 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x00000008
Sep 06 09:20:59 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x00000009
Sep 06 09:20:59 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x0000000a
Sep 06 09:20:59 pc-laburo kernel: [drm:nv_drm_dumb_map_offset [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000b00] Failed to lookup gem object for mapping: 0x0000000b
Sep 06 09:20:59 pc-laburo bluetoothd[1303]: src/service.c:btd_service_connect() a2dp-sink profile connect failed for 1C:52:16:9C:FE:42: Protocol not available
Sep 06 09:20:59 pc-laburo bluetoothd[1303]: profiles/input/device.c:ioctl_is_connected() Can't get HIDP connection info
Sep 06 09:20:59 pc-laburo bluetoothd[1303]: profiles/input/device.c:ioctl_is_connected() Can't get HIDP connection info

Thanks for your help!
Alan

GRUB_TIMEOUT_STYLE=menu

No idea. dmesg looks ok, but what the kernel messages mean here from nvidia_drm… well no idea.

If only the trackpad support is important, then you are better off to use the nouveau driver on wayland. Just remove nvidia.

I just fixed it in the tutorial. Use:

gsettings set org.gnome.mutter experimental-features '["kms-modifiers"]'

GRUB menu is back, thanks! I can’t use nouveau because I need NVENC too. Well, I guess this is it, no Wayland for me, at least for now…

It worked, thanks! Still the same behavior in my system though, so I’ll try to roll back the steps taken when following the tutorial.

Maybe, I am not sure, this device could be the problem:

I can use wayland with my nvidia card. Maybe remove it?

Not a possibility. I recently installed it and I badly need it for my day to day work :frowning:

I mean, just for the testing propose, to exclude that this device is the problem in any way. But ok, I understand if this computer is for work.