I don't know enough to be able to update the (1) AUR pkg I installed in my system

I enabled the AUR and installed 4K video downloader and it wants to install the latest version so I downloaded it. but read up a little on the AUR but still don’t find what I need in order to update this package. I tried - pamac update -a
after refreshing the AUR , socket I/O timed out.
Failed to synchronize AUR database
Checking smtube dependencies…
Resolving dependencies… anyway , it only saw and offered to edit the build files for smtube , which I don’t need . I don’t know how to offer it the 4K files I have in my download folder; which it doesn’t see. I could really use some help

Can you rephrase your issue / question?

It’s hard to follow at the moment.

I want to update the 4Kvideo downloader package I installed from the AUR but don’t know how.

So you installed 4kvideodownloader from the AUR.

It installed as expected.

Then you realized (or were notified by the application itself) that a new version exists.

Yet the version on the AUR is outdated.

If this is the case, then you’re left with a few options:

  • Flag the PKGBUILD as “out of date”. (Someone already did this.)

  • Modify the PKGBUILD to use the latest version from upstream. (This requires some knowledge about packaging and the the PKGBUILD format.)

  • Download and install 4K Video Downloader from a different source.

  • Use an alternative application, such as yt-dlp or its GUI derivatives.

Alternatives include:

  • yt-dlp (available on the official repository, command-line only)

  • media-downloader (available from the AUR, GUI that uses Qt5, and yt-dlp as a backend if installed)

  • ytdownloader (available from the AUR, GUI that uses GTK3, and yt-dlp as a backend if installed)

+1 GUI alternative;

clipgrab - available from official repo, uses qt5-webengine and yt-dlp backend

highly recommend all suggestions, and all trump 4kdownloader, which has limits on playlist sizes and number of videos you can download per day. yt-dlp downloads from many sources (if not all). so no limitations there. clipgrab does everything, 4kdownloader can



thanks to both of you for your help.
I’ve had a subscription to 4k for a couple of years , so I was glad to find it in the aur. I recently tried yt-dlp and ytdownloader and looked on youttube for help etc. but every thing I tried I failed at it. . clipgrab seems slow and I couldn’t figure out how to download more than 1 at a time.
I guess I’ll just “ignore” 4k’s update message and wait for the maintainer . it is very fast , even on my motel wifi. sometimes. I will try media-downloader too.
my problem is I’m not savy with qt5 versus gtk3 etc. or much of anything. including KDE, Plasma,
and even Manjaro. I just struggle along. never been in an office environment or known ANYONE who could help with Linux .

To update a package from the Arch repository:
type pamac update -a in your terminal
this will update all packages from the Arch repository installed

pamac -R (package name) will remove the package alone and
pamac -Rs (package name) will remove the package and all of the dependencies installed with it

thanks, but the version on the AUR is outdated. my problem is I have the updated version but installing it is beyond my knowledge.
I checked here - PKGBUILD - ArchWiki - but these build things are beyond my experience.

I did install media-downloader and it installed ok for me and looks nice. I will try it soon.

A good PKGBUILD is one that only needs a small revision to work with updated software from upstream.

In the case of 4kvideodownloader, you only need to change two values, and it should properly build and install.

Change the pkgver number to this:


Change the first SHA256 checksum to this:


Now you can build and install it with Pamac’s GUI itself (by editing the PKGBUILD file).

Or manually with makepkg and pamac.

This will result in the latest version of 4K Video Downloader on your system, and fully managed by your package manager, just like any other package.

You can give this a try right now.

In Pamac’s GUI, find the package 4kvideodownloader and force it to rebuild by clicking on the Build button.

Now click Apply in the bottom of Pamac’s window.

Then when prompted, click on Edit build files, and make the above two changes under the PKGBUILD tab.

(If you view this PKGBUILD’s history, you’ll see that this is essentially all that the maintainer does: change the version number and SHA256 checksum. Publish. Done.)

1 Like

thank you very much. I’m game . but, can you walk me thru this a little more explicitly ?- what I mean is - go here do this step- next , go here do this

question- when you say Pamac’s GUI , is that in add/remove or in the terminal? I checked in add/remove and went here- AUR (en) - 4kvideodownloader - but don’t see anyway to change the version - so I’m sure that’s not right. I really don’t know how to cd into directories in the terminal . I did find 4k files in usr/bin yesterday but ??
so , what I’m getting at is I don’t know where to go to change the pkgver - however going here -PKGBUILD - aur.git - AUR Package Repositories I’m pretty sure I need to go to config file for 4k - I searched in root/ in Dolphin but it returns nothing - so I don’t know where the config files are. I never changed a config file before.

anyway , am I on the right track ?

The “friendly” name of the Pamac GUI is “Add/Remove Software”. It’s the package manager and updater you might find as a tray icon, in which Manjaro users launch this to install, remove, and update packages.

Launch “Add/Remove Software” to bring up the Pamac GUI.

Then simply follow the instructions above.

No need to manually download anything or try to fiddle with config files or Dolphin. No need to visit any website or GitHub.

of course . so simple . gotcha

what is the proper way to place the 4k files into “temp” folder - do I place the tar file into temp or extract it first - or what - because it isn’t in temp so add/remove doesn’t find it

add/remove - Failed to generate 4kvideodownloader information

I think I made a mistake when I copied and pasted the sha256. I think I corrected it and now the 4k version is the latest 4.22

thank you

1 Like

For my own curiosity, since I’ve seen this multiple times in the past: May I ask why you marked you own post as the solution?

I’m not upset, just very curious.

Imagine you’re browsing the web, using a search engine, and you come across a thread. You click on “view solution” and you are taken to a post that reads “it works, thanks”. :sweat_smile:

1 Like

Winnie, I had already marked it solved earlier and I tried to unsolve it because we kept adding more posts to it and I thought it should be at the end but I didn’t find where I had marked it solved so I couldn’t unsolve it But to answer your question explicitly I hit the solved button simply because my issue is now solved. I think it was actually solved in two or more of your posts. I just thought it needed to show solved and I wasn’t certain it should be according to posts or according to the thread in general. There are probably other unknowing souls who also do that.

I was thinking about this some more and the real answer is I’ve never really been in PC environments I’ve always been a lone user with limited experiences and so I don’t know etiquette and protocols and so on.

It’s not really a big deal, let alone solely due to etiquette.

But when a user clicks on “Solved by ___ in post #_, it takes them to the post in which they can follow the steps (or read the explanation) of how to solve this issue (or related issues.)

Yes I understand now. There was a time I used the forum more often also way back I was on Linux mint forum and I got to be somewhat familiar in general with things. These days I go to the forum only two or three times in a year? Seems like when I do learn a little something it’s not anything that I use a lot and so don’t really learn it or remember it. Yes yes I realize it isn’t only for etiquette.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.