I don't have permission to change flatpak icons

When I go to change icons in both manjaro, and my kali machine using kde, or gnome, it will return an error when i go to the “edit application” tab, and try to pick a different icon. This is likely to be a silly fix, but any help would be appreciated

The default application information is installed when the app is installed to /usr/share/applications. When I go to override it (on KDE), it places a new file in ~/.local/share/applications. Is it possible this folder has incorrect permissions? I’m assuming per your title that the error says something about incorrect permissions, though it might help if you specify.

EDIT: Ah, and now I’ve actually tried it on a flatpak app - and I get the permission error. :slight_smile: As it tries to change the .desktop file in the folder where the flatpak app is installed instead of creating an override file - because instead of putting the desktop file in /usr/share/applications where KDE looks by default, it instead creates a symlink to the desktop file in ~/.local/share/applications. A workaround would be to replace the symlink with a copy of the desktop file, or to adjust the permissions of the original desktop file to allow you to write it. Not sure if there is a way to change the behavior of flatpak. Interestingly $XDG_DATA_DIRS (at least for me) already contains /var/lib/flatpak/exports/share/applications, so not sure why the symlink is created (or if that was something weird in my environment)


The nature of flatpak is that the self-contained (containerised) app is by design isolated from the system - this can sometimes extend to theming. An obvious workaround to enable selecting icons might indeed be to use the package available in the official Manjaro repositories, if it exists, before considering containerised apps or other alternatives.

That is all. Cheers.