I changed the mount point of my 2nd ssd and now i cannot boot

TL DR : I am running manjaro KDE
1st drive is 250gb ssd with root on it and the second 1tb nvme. it was being automounted with kde before i disabled it and changed the mount point. now i only have a cursor and no desktop.

So i wanted virt manager to use an iso from my 2nd ssd since it has more space but it kept saying it doesn’t have permissions and bla bla. i tried chown, i tried editing the libvirt.conf file to change it from session to system. it still wouldn’t ■■■■■■■ just use a drive i have attached to my motherboard. i know i could sudo virt-manager but i didn’t want to do that everytime i use my VM.

then i read somewhere if you change the mount point of the drive from /media to /dev. it fixes the issue.

so i ran kde partition manager and unmounted the drive and changed the mount point to /dev. i think i should’ve made another folder inside so maybe that’s my fault.

after this i used dolphin to mount it and it just froze the entire thing. my cursor was moving but nothing else. ctrl alt T or anything like that just doesn’t work.

i hard restarted and it says “failed to start remount root and kernel file system”

I did try to edit grub boot menu by pressing e and booting into /bin/bash. it does get there but my keyboard doesnt work. I tried connecting it to a different usb port but it still doesnt work.

i just wanted to use a different drive man, why is this so hard.
do i have to wipe everything and install manjaro on a 1tb ssd just to have to not worry about this?

/dev is a virtual-memory-based filesystem created by the kernel and populated with the device special files which ─ among other things ─ represent the hardware in your computer. If you mount anything else at /dev while the system is running, then the original contents of /dev are no longer accessible, and by consequence, your kernel won’t find any hardware and any partitions in your system anymore.

The bottom line is that you should not be messing with things you do not understand, and blindly following some instructions you read on the internet is equally dumb.

The good news is that the problem can be fixed. Boot up from the install medium in live mode, mount your root filesystem, and edit its /etc/fstab to remove the entry that mounts your additional partition at /dev.

Further reading… :arrow_down:

1 Like

Thank you for the response. Its fixed now.
As I said I only wanted to be able to use the drive with more space. I didn’t know how to do that and the regular solutions didn’t work for me. So should I just not use my drive because I am not a linux expert?
If I don’t follow what I read on the internet, how will I fix anything that I don’t know?

The first information source to consult should always be the forum of your distribution. We could have spared you the agony. :stuck_out_tongue:

See above. :slight_smile: Besides, you should have familiarized yourself with the process of mounting and mountpoints before messing with them ─ there is ample documentation on the internet, as well as on your local system, such as the man pages. :arrow_down:

man apropos
man mount
man fstab


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.