I Can't Update My Flatpaks

Hi, when i try to update with flatpak update i get

Looking for updates...
Nothing to do.

Pretty fast and when i try to repair with flatpak repair i get

The flathub remote for the ref runtime/nl.hjdskes.gcolor3.Locale/x86_64/stable is disabled
The flathub remote for the ref runtime/org.freedesktop.Sdk.Locale/x86_64/21.08 is disabled
The flathub remote for the ref runtime/org.freedesktop.Platform.Locale/x86_64/21.08 is disabled
The flathub remote for the ref runtime/com.usebottles.bottles.Locale/x86_64/stable is disabled
Flathub remote for ref app/com.google.chrome/x86_64/stable is disabled
The flathub remote for the ref runtime/org.freedesktop.Platform.GL32.default/x86_64/21.08 is disabled
Flathub remote for runtime/org.gtk.Gtk3theme.Matcha-dark-sea/x86_64/3.22 ref is disabled
Flathub remote for ref runtime/org.freedesktop.Sdk/x86_64/20.08 is disabled
The flathub remote for the ref runtime/org.gnome.Platform/x86_64/42 is disabled
The flathub remote for the ref runtime/org.freedesktop.Platform.GL.default/x86_64/21.08 is disabled
Flathub remote for ref runtime/org.kde.PlatformTheme.QtSNI/x86_64/5.15-21.08 is disabled
Flathub remote for ref runtime/org.kde.Platform.Locale/x86_64/6.2 is disabled
The flathub remote for the ref runtime/org.freedesktop.Sdk.Locale/x86_64/20.08 is disabled
Flathub remote for runtime/org.kde.PlatformTheme.QGnomePlatform/x86_64/6.2 ref is disabled
The flathub remote for the ref runtime/org.kde.PlatformTheme.QGnomePlatform/x86_64/5.15-21.08 is disabled
Flathub remote for ref runtime/org.kde.WaylandDecoration.QGnomePlatform-decoration/x86_64/6.2 is disabled
The flathub remote for the ref runtime/org.freedesktop.Platform.ffmpeg_full.i386/x86_64/21.08 is disabled
The flathub remote for the ref runtime/org.freedesktop.Platform.ffmpeg-full/x86_64/21.08 is disabled
The flathub remote for the ref runtime/org.gnome.Platform.Locale/x86_64/41 is disabled
Flathub remote for ref app/net.davidotek.pupgui2/x86_64/stable is disabled
The flathub remote for the ref runtime/org.gnome.Platform.Compat.i386/x86_64/42 is disabled
The flathub remote for the ref runtime/org.gnome.Platform.Locale/x86_64/42 is disabled
Flathub remote for ref app/com.usebottles.bottles/x86_64/stable is disabled
The flathub remote for the ref runtime/org.freedesktop.Platform.GL.default/x86_64/20.08 is disabled
The flathub remote for the ref runtime/org.winehq.Wine.DLLs.dxvk/x86_64/stable-21.08 is disabled
The flathub remote for the ref runtime/org.winehq.Wine.gecko/x86_64/stable-21.08 is disabled
Flathub remote for ref runtime/org.kde.WaylandDecoration.QGnomePlatform-decoration/x86_64/5.15-21.08 is disabled
Flathub remote for ref runtime/org.winehq.Wine.mono/x86_64/stable-21.08 is disabled
Flathub remote for ref app/com.github.tchx84.Flatseal/x86_64/stable is disabled
Flathub remote for runtime/org.freedesktop.Platform.openh264/x86_64/2.0 ref is disabled
Flathub remote for runtime/org.gtk.Gtk3theme.Adwaita-dark/x86_64/3.22 ref is disabled
The flathub remote for the ref runtime/org.freedesktop.Platform/x86_64/21.08 is disabled
Flathub remote for ref runtime/org.kde.Platform.Locale/x86_64/5.15-21.08 is disabled
Flathub remote for ref runtime/org.kde.Platform/x86_64/6.2 is disabled

I already checked the support in the software manager and reinstalled the repo:

flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo

Any help would be appreciated :slight_smile:

Nothing to do. All is updated. What makes you think that it needs to be updated?

Look a list of flatpak-repositories (no sudo!):

flatpak remotes

If the list is empty, try tp enable a main repository:
flatpak remote-modify flathub --enable

1 Like

Thank you very much! that did the trick :partying_face:

1 Like

unusual time for updates :upside_down_face:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.