I can't start Manjaro ARM on Nanopc-T4

I made the boot card and image of manjaro arm according to the tutorial in the link(https://forum.manjaro.org/t/can-i-install-manjaro-on-nanopc-t4/24026),and tried to burn the image to emmc (through dd). However, neither the boot card nor the EMMC can start manjaro arm normally.
After the board is powered on, the output of the debug serial port is as follows:

U-Boot TPL 2020.04-1 (May 26 2020 - 20:53:05)

Channel 0: LPDDR3, 933MHz

BW=32 Col=10 Bk=8 CS0 Row=15 CS1 Row=15 CS=2 Die BW=16 Size=2048MB

Channel 1: LPDDR3, 933MHz

BW=32 Col=10 Bk=8 CS0 Row=15 CS1 Row=15 CS=2 Die BW=16 Size=2048MB

256B stride

256B stride

Trying to boot from BOOTROM

Returning to boot ROM…

U-Boot SPL 2020.04-1 (May 26 2020 - 20:53:05 +0000)

Trying to boot from MMC1

Card did not respond to voltage select!

spl: mmc init failed with error: -95

SPL: failed to boot from all boot devices

ERROR ### Please RESET the board

I checked the contents of the extlinux.conf file and it was correct

FDT /dtbs/rockchip/rk3399-nanopc-t4.dtb
APPEND initrd=/initramfs-linux.img console=tty1 console=ttyS2,1500000 root=LABEL=ROOT_MNJRO rw rootwait bootsplash.bootfile=bootsplash-themes/manjaro/bootsplash

Looks like hardware failure to me where the card is not detected it happened to me on nanopi neo where the uboot card detection fails due to sd card slot switch failure.
This might be one of the reason, this link helped me.

Can it work on any other image running over sd card?
Or maybe this is a different variant of the board?

Can you share more information abouy your board?

It can run the official system (such as lubuntu) on the SD card.
Details of the card I use can be found in this linkhttp://wiki.friendlyarm.com/wiki/index.php/NanoPC-T4

At the same time, after burning manjaro arm on EMMC, it seems that SD card cannot be detected normally. If I press and hold the boot key when starting, I can force the official system to boot from SD card. However, if I do not press and hold the boot key when starting, the debug serial port will output the same error

It is very hard to understand what might be wrong with the image as no one from Manjaro arm Team have a sample device to test.

We had one community volunteer to test it for us.
Let me find out that volunteer and tag him/her here on this thread.

Thank you!
If necessary, I can volunteer to help you test.

Hello. Sorry to ask this question in this thread, but I am a newbie and cannot create my own theme.
I saw that there is support for NanoPC T4 in the assembly packages, but unfortunately I did not see support for NanoPi M4. Can you please tell me if you plan to add this device to the list of supported ones?
Sorry for my English.

I think you can try to use the T4 image on M4, because on the official system, M4, T4 and neo4 use the same image.
My English is translated by using translation software, so there may be various errors.

Can anyone help me?