I can't set Brave as default browser

Hi guys,
I need some advice. I’m just an old man and an ordinary user, not an expert.
I use Brave across my units. A laptop and two android units. I’m not able to set Brave as default browser. I asked ChatGPT but it didn’t help. I tried this commands, with and without sudo.

xdg-settings set default-web-browser brave-browser.desktop
xdg-mime default brave-browser.desktop x-scheme-handler/http
xdg-mime default brave-browser.desktop x-scheme-handler/https

Thank you!

please check this: open your system-settings, search for applications, there is a menu for the standard-applications where you can change the setting for the browser

Hi there,
It looks ok as far as I’m concerned?

does it work now or still issues ?

This should be enough on plasma - no need for sudo either.

Check the file ~/.config/mimeapps.list.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.