I can't seem to remove Xscreensaver

Hi All,
I used Pacman to install Xsceensaver.
I tried it but it wasn’t for me so I right clicked on it in the menu and selected uninstall.
At first Pacman gave me a dependency error when trying to remove it but after a few attempts it eventually worked.
Or so I thought.

It now appears in the “Lost and Found” menu and it still appears when I search All Applications.
The icon has changed, it is now just a generic grey page with a corner folded over.

When I look up Xscreensaver in Pacman, the only option it provides me is to install it.

So I’m a little confused and wondering how to properly and completely remove Xscreensaver once and for all.

Note, I have tried rebooting but No Joy.

pamac you mean?

Lets use pacman though:

pacman -Qs xscreensaver

If its there…

sudo pacman -Rns xscreensaver

As to reconfiguration …
What did you use before ? lightlocker , xfce4-screensaver, nothing ?
We dont know your DE, etc.

LOL Yes I meant Pamac. Pacman does have a nice ring to it though. :laughing:

I had tried Xsceensaver previously and removed it (at least I think it was removed) but thought I’d try it again.

I am using KDE.

Ok,I tried it and got a “target not found” result.

So I tried reinstalling Xscreensaver and then immediately uninstalling it.
It temporarily disappeared from the Lost and Found but it’s back.

I’m stumped.

Well here’s an update for you.

I have tried installing and uninstalling Xscreensaver again to see if I would have any luck.
And while Pamac says it has uninstalled it, it not only still appears in the mainmenu, when I click on it I cannot access the program AND it is still running.

I can’t remove it, I can’t access the settings and I can’t stop it from running.

I looked up the file name and location in Pamac, thinking that worst case scenario I could manually delete them.
However when I try to locate them using Dolphin, they don’t appear.

This is a real head scratcher for me.

If anyone is able to help me remove Xscreensaver, that would be greatly appreciated.

I hope I’m not out of options other that reinstalling Manjaro.

Highly doubtful that you use Pacman or Pamac based on your vague descriptions that don’t match that statement… :point_down:

What menu? What program?

…that still tells us absolutely nothing.

I’m completely lost.

No one can help you if you can’t tell us what you actually did.

Please see:

My applogies @Yochanan, I thought I had provided the relevant information above:

I used Pamac, which I had incorrectly called Pacman in my original post.

There is a main menu item called “Lost and Found” in KDE

Apologies again for not being clearer in post, I thought I had identified the issue I was having and the steps I took to resolve it, and the desktop that I was using.

I have since discovered that this isn’t solely a Xscreensaver issue.
I have experienced something similar with Shotwell (it still appears in the Graphics menu in KDE but not the Lost and Found menu.
I will of course start a new thread for this since it seems to be an issue that affects more than one program.

I dont know what this is.
Maybe you can explain further ?

… doing a search it might be something like this:

And I would guess it still has to do with a remnant .desktop file.
But those should be removed along with any package, though I suppose you can go looking in

1 Like

In KDE there is a menu item called “Lost & Found”.
It appears near the bottom of main menu, right above the “Help” menu item.

I used Pamac to find the file location but when I tried to find them manually using Dolphin, they weren’t there.

Xscreensaver is still running.

I didnt ask for the locations of all files … I asked to look for the .desktop file specifically in specific locations…
If you have not rebooted or killed the process … then if it was running it might still be in memory.

If you are on KDE … what steps did you take to enable/start/use xscreensaver?
(as plasma seems to require additional steps)

I looked in /usr/share/applications but did not find anything.
I could not find /.local/share/applications

Many thanks for your help @cscs, I really appreciate it.

Yes I did look in the locations you mentioned (please see my post above, they crossed paths).

I have rebooted several times, but the issue persists.

The first time you open Xscreensaver (I selected it from the main menu in KDE) you are presented with Settings that you can change.
But after that first time, I was never able to get back to the Settings.
When I try to open Xscreensaver, I don’t see anything at all.

Even if I could get back to the Settings and change the timings to several hours before it starts, I would essentially still have a program running in the background that I don’t need or want running, hence if I could find a way to remove it it would be preferable.

I have also noticed that there is another program that I installed and removed with Pamac that still appears in the Graphics menu in KDE.

I also looked for it in the directory you cited in your earlier post but neither it or Xscreensaver was listed there.

If you had, no one would have had to ask questions. :wink:

Done and solved.

Wait, what? It’s not solved you say? Well, until you give us the roadmap detailing how you managed to find your way into your predicament, there’s no way anyone can help you find your way out of it.

Yes, I already tried that and replied:

Here’s a simple roadmap for you:

  1. Install Xscreensaver using Pamac.
  2. Open Xscreensaver from KDE main menu and proceed to select screen saver from list.
  3. Later decide to make change and try to re-open Xscreensaver from KDE main menu, nothing happens.
  4. Uninstall Xscreensaver using Pamac.
  5. Discover Xscreensaver is still listed in KDE main menu and now appears in “Lost & Found” sub menu.
  6. Also discover the Xscreensaver is still running (it overrides the power management settings in KDE to bring up the logout screen every five minutes of inactivity).
  7. Search forums for solution to problem, didn’t find one.
  8. Post here looking for some help.

By the way, I don’t know if you caught this but I have installed and uninstalled another program, Shotwell, using Pamac and recently discovered that it too still appears (in the KDE Graphics submenu but it is not in the Lost & Found sub menu, also no longer running).
So I suspect that this may not be an issue that is isolated to Xscreensaver.

Edit: I had also added both of these programs to the Task Manager by right clicking them and selecting add to Task Manager.

I hope this helps.

1 Like

That’s a bit more clear, thank you.

Unfortunately, I don’t have any ideas. I’m not very familiar with KDE and had never heard of the Lost & Found menu.

Quite possibly since you stated it happened with Shotwell.

Finally, I was able to remove the icons from the menus!
@cscs was right all along, I just hadn’t realized that the /.local/… directory was a hidden directory.
Many thanks to @Ben who, in a different thread, pointed out that this was a hidden directory and that all I had to do was delete the unwanted files from there.
Kudos to you both for kindly and patiently helping this Newbie.
I really appreciate it.

Now to figure out why my computer keeps going to login screen after five minutes of not using the keyboard or mouse.

Edit: I found the Login screen settings in the System Settings and turned this off.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.