I can't save to the desktop

Hi, I’m a newbie because I installed the system yesterday. I’m using WPS Office (I know why not libreoffice… I like it) I want to save my documents on the desktop but I’m missing some permissions and I can’t get it to work. I have searched the web in vain and found nothing. The attached picture shows the problem.

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information.
  1. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
sudo inxi --verbosity=8 --filter --width 
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.
  1. Or we can try to play hide and seek :wink:
    Have you already :mag: for your problem in the forum ? (Wisdom lies in asking → listening → reading :wink: )

Did you do what the message says?
What was the result of the check?

ls -al /home/administrator/Desktop

should do - no need to share everything, just the first three lines of the output
(we don’t need to see the names of files in there)
if you don’t know what to make of it

Is /home/administrator your normal user account and are you logged in there when you try to save to this location?


Actually, it should be… :point_down:

ls -l /home/administrator

The -a is not required, and looking at home/administrator/Desktop will give you the contents of that directory, not the directory itself — although in your case, with the -a, it would of course also give you the permissions on the “.” entry inside the directory. :wink:

so what does that mean to you - what can it and what can it not tell me?

ls -al /home/jo/Desktop
total 1636572
drwxr-xr-x   8 jo jo      4096 Jul  4 00:41  .
drwxr-x---+ 56 jo jo      4096 Jul  8 16:24  ..
a lot of files and directories

It means that…

  • /home/jo/Desktop is owned by you, and you have read, write and traverse permission on it.
  • /home/jo is owned by you, with the same permissions, but it’s only readable and traversable to yourself and other members of the group jo, but inaccessible to anyone else (except for root, of course). :wink:

With regard to the OP’s problem, permissions within one’s home direcory don’t rewrite themselves, so either OP has changed those permissions by using some careless command they found at Reddit or wherever, or the WPS Office they are using is not from the AUR, but rather a Snap or FlatPak, both of which run containerized and don’t have full access to the underlying filesystem.


I reinstalled from AUR (third time) and now it works perfectly. Thanks guys!

I must say this kind of solution is a bit disappointing, because with this “information”, no one can know or learn anything about the cause or reason. :man_shrugging:


Educated guess: The OP had indeed been using a FlatPak or Snap earlier, and has now tried the AUR version instead, which unlike with the FlatPak/Snap package, actually works. :stuck_out_tongue:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.