I can't restart my MariaDB

when i run my wordpress website i see that error Error establishing a database connection and after that i login to my vps from putty and now i want to restart the database with that simple line systemctl restart mariadb, and it’s gives me that error:

root@racknerd-d813b2:~# systemctl restart mariadb
Job for mariadb.service failed because the control process exited with error code.
See "systemctl status mariadb.service" and "journalctl -xeu mariadb.service" for details.

please help to fix it !

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Start there?

this is what i see when i run “systemctl status mariadb.service”:

root@racknerd-d813b2:~# "systemctl status mariadb.service"
systemctl status mariadb.service: command not found
root@racknerd-d813b2:~# systemctl status mariadb.service
× mariadb.service - MariaDB 10.11.7 database server
     Loaded: loaded (/lib/systemd/system/mariadb.service; enabled; vendor preset: enabled)
    Drop-In: /etc/systemd/system/mariadb.service.d
             └─migrated-from-my.cnf-settings.conf, protect.conf
     Active: failed (Result: exit-code) since Sat 2024-04-20 16:48:16 UTC; 2min 2s ago
TriggeredBy: × mariadb.socket
       Docs: man:mariadbd(8)
    Process: 8259 ExecStartPre=/usr/bin/install -m 755 -o mysql -g root -d /var/run/mysqld (code=exited, status=0/SUCCESS)
    Process: 8260 ExecStartPre=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS)
    Process: 8262 ExecStartPre=/bin/sh -c [ ! -e /usr/bin/galera_recovery ] && VAR= ||   VAR=`cd /usr/bin/..; /usr/bin/galera_recovery`; [ $? -eq 0 ]   && systemctl set-environment _WSREP_START_PO>
    Process: 8387 ExecStart=/usr/sbin/mariadbd $MYSQLD_OPTS $_WSREP_NEW_CLUSTER $_WSREP_START_POSITION (code=exited, status=1/FAILURE)
   Main PID: 8387 (code=exited, status=1/FAILURE)
     Status: "MariaDB server is down"
        CPU: 121ms

Apr 20 16:48:16 racknerd-d813b2 systemd[1]: Starting MariaDB 10.11.7 database server...
Apr 20 16:48:16 racknerd-d813b2 mariadbd[8387]: 2024-04-20 16:48:16 0 [Warning] Could not increase number of max_open_files to more than 32768 (request: 65535)
Apr 20 16:48:16 racknerd-d813b2 systemd[1]: mariadb.service: Main process exited, code=exited, status=1/FAILURE
Apr 20 16:48:16 racknerd-d813b2 systemd[1]: mariadb.service: Failed with result 'exit-code'.
Apr 20 16:48:16 racknerd-d813b2 systemd[1]: Failed to start MariaDB 10.11.7 database server.
lines 1-21/21 (END)
root@racknerd-d813b2:~# ^C

Just a web search: MySQL/MariaDB [Warning] Could not increase number of max_open_files to more than 32768 (request: 100000) - WP Beaches

This is not Manjaro or any Arch based Distrubition. You should search for a support forum for the distribution you are running on this server.

1 Like