I Can't open any website!(temporary failure in name resolution)

Hi there,
i tried to install protonvpn. after that, i couldn’t use that, then i remove the proton vpn. but now when i try to open any website show this error:
temporary failure in name resolution
i edit /etc/resovle.conf file but it didn’t work.
plz help me!

Hello @Cronus :wink:

Look at the notes (killswitch): How to install the ProtonVPN Linux app on Archlinux and Manjaro 19

1 Like

Hi @megavolt
thank you for your comment!
but i don’t like install protonvpn again just i want fix my linux.
Do i need install it again?
I can’t install any package because my linux can’t resolve domain! even with VPN!

Dear @Cronus,

when I said “look at”, then I don’t mean read the link, but read the content. What don’t you understand by saying “notes” and “kill switch”?


2. Disable Kill Switch if you have uninstalled the app

The Kill Switch can be easily disabled from within the official Linux app, but this will not be possible if you uninstalled the app without first disabling the Kill Switch. This may result in your system being unable to access the internet. To remove the Kill Switch after the app has been uninstalled:

a) Identify Proton VPN connection names by running the command:

nmcli connection show --active

This will display a list of all your system’s active connections.

b) Look for any connections with the pvpn- prefix. This usually includes pvpn-killswitch and pvpn-ipv6leak-protection, and may include pvpn-routed-killswitch. Delete all these connections using the following command:

nmcli connection delete [connection name]

For example:

nmcli connection delete pvpn-killswitch

c) Re-run the following command to verify that Proton VPN connections have been deleted:

nmcli connection show --active

If any Proton VPN connections remain, delete them as described above.

1 Like

thank you.
solved :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.