I can't get freesync to work on my system (ryzen 3 2200g and gigabyte g32qc)

I’m completely new to manjaro. I switched from Kubuntu to Manjaro KDE a couple days ago, and for the most part the process has been surprisingly easy, except for this one issue. I tried to enable freesync by following the steps listed in the arch wiki, but it didn’t work. xrandr --props lists my video card as being vrr_capable: 1, and I have freesync turned on in my monitor’s settings. An amdgpu.conf file did not exist on my computer, so I created one and added the appropriate text lines according to the arch wiki. I know that I created the amdgpu.conf file correctly, since it successfully changed my tearfree setting to on (it was set to auto by default). However, it did not change my freesync setting, which I confirmed with the systool -vm amdgpu command. This command gave the output freesync_video= “0”. I only have one monitor set up, and I am using a displayport cable to connect it to my computer. Does anyone have any tips for getting freesync to work? I do see some small issues with tearing in cs:go and it would be cool to have freesync, especially since my monitor supports it.
Thanks, DAV1326

Try with boot option amdgpu.freesync_video=1

Edit /etc/default/grub on line GRUB_CMDLINE_LINUX so that, assuming no other options are there, it will look like this:


Then run:

sudo update-grub

(and reboot)