I can't get any browser to work and don't know why

I’m new to Linux in general (switched to it literally yesterday) however I’m having an issue where I can’t get any browser to work. I installed discord and it works just fine however for the browser programs which I’ve tried Vivaldi, opera, chromium, and Firefox and I’ve tried to do it three different ways, through manjaro hello, through the add or remove software thingy and even searching up and trying through the terminal. They all install (or atleast appear to) but when I try to open them it does the spinny loading thing in place of the cursor for a lil bit and then nothing. They don’t open? And I have no idea why. I thought it was an issue with applications in general but installing discord worked perfectly so idk. Pls help. For context I’m using manjaro cinnamon

After you freshly installed the system, you already have at least one browser.
I know of no ISO where none is preinstalled - but we don’t know which one you used or how old it was.

To install another one, another browser, first refresh the list of mirrors and update the system
before you install any new software.

you know what you did there - we don’t, unless you tell us

there is always the other way, which will tell you more about the reason for failure:
start a terminal, then start the program by typing it’s name
the terminal output usually is somewhat enlightening :nerd_face:

So I’ll respond to this tmrw but it’s late so I’m tired but I will say I managed to get it open…kinda. so I’m still incapable of opening it normally but I tried setting it as an application that opens on start and then restarted my PC and it’s open and usable…Im not sure if I would be able to get it open if I closed it but it’s progress. Atleast I know the application is capable of opening to some extent

I do not know what this “tmrw” means …

What you are saying in the post lacks substance - nothing concrete in it.
We can’t see what you see …

I strongly suggest that as someone new to Linux you should choose one of the officially supported desktop editions - KDE, GNOME, or Xfce.

Cinnamon is a community edition which means it’s built and supported by the Manjaro community. In practice that often means just one person, and the ISO may not be updated as regularly. From what I can see the current Cinnamon 23.0.1 ISO is 8 months out-of-date and is still using Linux 6.5 (which was end of life a long time ago - the first thing you’d need to do is install a newer kernel like 6.6 LTS).


I have to agree with the post from @MrLavender in its entirety. Of the three official Manjaro versions XFCE is probably the closest to Cinnamon, it general appeal. However, you might find the new KDE Plasma 6 to your liking. It’s just a download away. Cheers.


Unofficial Manjaro 24.0.0 Cinnamon release:

I tried it - I like it!

I installed the same (old) version of Manjaro Cinnamon that you used (the minimal edition).
Installs flawlessly - but needs an immediate and big update.

Midori is the default internet browser and the only one installed.
It was barely able to display the google search site
and it choked on youtube - coredump, again and again

So: I removed it - you want to install another one anyway.

This is the process to update the system to get it current and in a usable state:
It is a big update - a lot of packages got updated since the time the ISO was created.

sudo pacman-mirrors -c Germany
sudo pacman -Rns midori
sudo pacman -Syu
(answer every question with ENTER to choose the default answer - which is Y most of the time, sometimes a numerical choice)

sudo pacman -Syu firefox mc
(this installs firefox and mc - a file manager that I use all the time)

sudo mhwd-kernel -i linux66
(install a supported kernel)


sudo mhwd-kernel -r linux65
(remove the unsupported kernel)


  • First update your system completely
    pamac update

  • Did you check the md5, sha of this ISO?

T+ = See you later

Tmrw just means tomorrow lol. It was 12am for me so I had to go to sleep hence saying I would respond to the things you asked for tomorrow. Unfortunately I’m not near my PC so I can’t do the things and tell you what I tried (cause Ive forgotten) but I’ll reply again when I’m at my pc

The one I installed has Vivaldi as the default browser. I got it through just the manjaro site. However I will do the things youve said though I’ve already tried updating the system with -Syu there was one update missing that I did and then I rebooted it and the issue persisted

Vivaldi is included on the Full ISO version - manjaro-cinnamon-23.0.1-230921-linux65.iso.pkgs

Try to launch browser from the terminal and share any errors here.

I got my ISO from the same source - I chose the minimal version while you chose the full version with more software preinstalled.
Both should still be pretty much the same.
The ISO is quite old and an installation done using it needs to be updated
before you can attempt to install new software.

Just skip the second command I gave in my procedure to update the thing.
This one:
sudo pacman -Rns midori

Bottom line:
You need to update and bring the system to a current state before you can attempt to install anything new.