I can't download Mongodb

I get this problem when trying to download Mongodb-bin
I think it’s because of pamac

sudo pamac search mongodb-bin  
sudo pamac build mongodb-bin  

resulte :

Warning: Building packages as dynamic user
Warning: Setting build directory to /var/cache/pamac
Checking mongodb-bin dependencies...
Checking mongosh-bin dependencies...
Error: Failed to prepare transaction: invalid or corrupted database

Edit build files : [e] 
Apply transaction ? [e/y/N] y

Transaction cancelled.
  1. Please do not include screenshots of terminal output in your posts. Instead, copy the terminal output with your mouse, click the </> button in the toolbar of the editor, and paste the output where it is indicated. Screenshots take up room in the database, they are not searchable by the forum’s search engine, and they cannot be copied from.

  2. Please fully update your system first before attempting to install or build anything from the AUR, as below… :arrow_down:

sudo pacman-mirrors -f && sudo pacman -Syyu && pamac build mongodb-bin

Be sure to let the entire process finish, no matter how long it takes. Do not interrupt the update process, because you will render your system unbootable.

1 Like
  1. Sorry, I didn’t know about the picture ( screenshots )
    But I deleted it , Thank you for this information

  2. This may be another solution, but I tried this command

pamac update --force-refresh  

now it works

It’s basically the same thing, but given that there have recently been quite a few problems with pamac, the safer way was to have you update your databases by way of pacman. :man_shrugging:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.