I can't delete some files from an external device because of permissions

Manjaro is cool ,but i have a lot of problems,i don t know many things,and also about bios,everytime he has a problem with manjaro,doesnt read the SSD/M.2 if i have manjaro,its blocked on secure boot i can t disabled that,so sadly i need to go back to windows,but i can t delete manjaro from the USB Stick because i don t have acces and im absolutly a noob.

OK, this is confusing. You should really, really learn to use grammar.

And you don’t HAVE to go back to Windows, I think. I think I’ve read, somewhere on the forum the rEFI8nd works with secure boot. I don’t know for certain and neither do I have any experience with it, but it’s possible.

Also, you start off mentioning Manjaro is installed on an M.2 SSD, yet later you say you struggle with an USB device. It can also be both, but we need to know better what’s going on and what you wish to accomplish.

1 Like

Sorry,english isn’t my native language,my problem is that i can’t delete some files,because I don’t have permission to do it,i tried to give me permission but it says that i couldn’t do it.
And why i want windows back?I know how to use windows,with WINSCP(file transfer app and edit)i can emulate that app in manjaro,but using the default editor hurts my eye,i tried to use an external editor,like sublime text,but winscp is emulated so can’t read what is on my m.2,i have an ssd too,its empty,i wanted windows on it,but i can’t manage to do dual boot,because of the secure boot,i can’t disabled it,i tried for 3-5 days,i reinstalled those OS like 20 times in a week,tried a lot of things,tutorials and still nothing,i think my bios is locked on enabled at secure boot,and everytime i start my pc,the bios won’t read the M.2 so I can’t boot into manjaro,i need to enter the bios,and reactive boot priority,isn’t hard but it’s annoys me,also the stick isn’t mine so i need to clean it before i will give it back,but i can’t format/delete files from it because i don’t have permission to do so.
Once again,I’m sorry for my grammar.
EDIT:Or could i try to have 2 OS windows and manjaro,but because of the boot secure windows won’t regonize manjaro and won’t open the windows boot manager.

I have seen your topics and I think you would enjoy reading an article I once got Linked to - the last sentence reads

It’s not just about “Why should I want Linux?”. It’s also about "Why should Linux want me?"

Now why would I say that? Mostly because it appears from your issues that you are not ready for Linux - you are not ready to learn how to use a Linux operating system. You are not ready for the LEGO Technics Porche edition.

Linux != Windows | Why should Linux want me? - Frequently Asked Questions - Manjaro Linux Forum

If you want to skip the above introduction to the article you can find the article below


Thanks for the extra info,i realised that i don’t need windows(not from that link,i still didn’t read it yet)I can modify and customize Manjaro a lot,the only problem that i have now,is that i can’t modify or format the storage on my USB STICK,because of the permission,i tried like 2-3 commands,but they will give me acces only to read and not modify,i need to put windows on the stick,because if something happens to my brother pc,he will need windows(yes,he use windows and i borrowed the stick so i can install manjaro/pop os and zorin os,now i need to give it back).

If you can live with a FAT formatted stick then this may help

If you are using Linux file systems you need to understand filesystem ownership and permissions.

There is a lengthy article on the subject

Boiled down you need to mount the device - then change either the owner or the permissions on the stick’s filesystem. There is various tools and approaches to this but the dead simple one - which can be executed using a couple of commands in a terminal follows

Prerequisite - you know the device - e.g. it is listed by lsblk as /dev/sdy with one partition /dev/sdy1

Armed with the knowledge of your device address and partition number


$ sudo mount /dev/sdy1 /mnt

Assign world-wide read-write permissions to the any and all content of the stick

$ sudo chmod ugo-rwx /mnt -R


$ sudo umount /dev/sdy1
1 Like

Thanks for helping me!I read and applied the commands but still,i can’t give permission nor format the stick.
i wrote lsblk and I saw that my usb stick is called sdb,it has 14-15gb of storage,and i need to format it,i saw that something about 2GB its occupying(i guess Manjaro OS)at sdb1
I tried the commands, sudo mount dev/sdb1 /mnt and it gave back:
mount: /mnt: WARNING: source write-protected, mounted read-only
Now I continued the commands
sudo chmod ugo-rwx /mnt -R changed the permission to Read-Only files
then i tried sudo umount /deb/sdb1 and nothing happened,now I don’t know if i did something wrong,or I need to enable/disable something.

loop0 7:0 0 99,1M 1 loop /var/lib/snapd/snap/core/10958
loop1 7:1 0 55,4M 1 loop /var/lib/snapd/snap/core18/1997
loop2 7:2 0 57,2M 1 loop /var/lib/snapd/snap/sublime-text/97
loop3 7:3 0 61,7M 1 loop /var/lib/snapd/snap/core20/975
loop4 7:4 0 237,3M 1 loop /var/lib/snapd/snap/openjdk/284
sda 8:0 0 476,9G 0 disk
sdb 8:16 1 14,6G 0 disk
├─sdb1 8:17 1 2,7G 0 part /run/media/rezeryet/MANJARO_KDE_2103
└─sdb2 8:18 1 4M 0 part /run/media/rezeryet/MISO_EFI
nvme0n1 259:0 0 465,8G 0 disk
└─nvme0n1p1 259:1 0 465,8G 0 part /run/timeshift/backup

From your device map it appears you have the device mounted using e.g. a file manager.

You cannot change permissions for a ISO9660 file system.

In the file manager - unmount the usb - do not eject - just unmount or close the file manager and umount

$ sudo umount /dev/sdb1
$ sudo umount /dev/sdb2

Then create a script as the first link refers to.

When done you simply - execute the script with the identified device e.g. /dev/sdb (no partitions)

Damn,i know that this is easy for linux users,but I used windows for years,recently i had problems and a friend said to go to manjaro,but it will be dificult to do this myself,I’ll check the links and i hope that i can do it myself

Edit:I pasted accidentaly something and got mixed with a code about formmating and now I can’t remember what I wrote there.

I resolved the problem,I don’t know how,from what i remember the scrip failed to do something,but now when i checked in lsblk it said 14gb.I will never reinstall a Linux os on a stick,this is pure pain to remove it

different ways to reformat a device such as your USB thing:
if you have a working linux system
you can use the graphical tool “gparted”
several pseudo-graphical command line tools exist, too
such as “cfdisk”
… there is always “dd”
and “cat” will work as well
to delete the contents and remove any formatting
as a clean starting point

all of those have to be used with root/super user rights

The easiest thing to do is:
just give it back to whomever it belongs.

He/she will stick it in their Windows machine
and they will be asked to format it
since Windows cannot detect a filesystem on the device.

The stick will be re-formatted and all is good …

I know there are a lot of methods,but the one that i knew(Gparted)doesn’t work because of the permission.
Edit:I tried on his pc,he could formated like 4MB,the rest was invisible,i needed to delete it from a Linux machine

If it’s not your machine and you have no root/super user access
then of course this doesn’t work.
If it is your’s, you should know that password.

… if you start gparted, it should ask you for that password, to gain those rights that are necessary to perform the operation

… with gparted - and you want to start fresh:
new partition table …
and then create a new partition and format it as you like

I know,but the delete/format option were grayed and i couldn’t acces them,this is my pc so i know my password

in such a case
I simply use dd or cat to write some data to the device (not the partition on it)
sudo cat /dev/zero > /dev/yourUSB
and interrupt it after a few seconds … because it’ll fill the entire drive otherwise
sudo dd if=/dev/zero of=/dev/yourUSB bs=512 count=1

you want the partition information gone
which is at the start of the device

not the partition, the whole device …

if it’s not yours, the easiest is still:
give it back
let them stick it into their Windows machine
which will ask and then reformat it …