I can't create an SteamLibrary on my second hard drive

Hello everyone, newbie here on Linux, practically 2 days of using Manjaro KDE in specific.

Now, my problem is that when I try to create a new folder to install my games, Steam doesn’t recognize the other hard drive, only recognizes the main disk (an SSD where Manjaro is installed).
For give more information, I used a tool called “GNOME Disks” to convert the secondary hard drive to a format where Manjaro can use it, and most applications can use it, I can move files or download things from the web browser, but Steam still doesn’t recognize it.

Sorry if it’s seam so vague, I’m very (very) new to this things, didn’t even use the terminal or anything besides the “GNOME Disks” application. If you need more information or any question referring to the topic you can answer without problem (and sorry if the English is very basic or bad, but I’m not a native speaker, my native language is Spanish :slight_smile:)

That’s all, thanks for reading and hopefully responding. Bye!

You have to point Steam to the location where your drive is mounted. How are you trying to add your new library location?

Hi, I’m trying to add my new library location by going to steam>settings>downloads>steam library folders and clicking on the + symbol.
And for the part of point Steam to the location where your drive is mounted, I honestly don’t now how to do that, sorry for that.

Linux doesn’t work like Windows. You need to mount your drive for it to be usable by the system, it can be done temporarily by trying to access it from the file manager usually, but this is temporary and after reboot it will not be automatically mounted.

So first you need to make sure your drive is automatically mounted on boot, so it has a permanent access path in the system. When it is done, you can use it in Steam.

Also make sure you have formatted it as an EXT4 partition so it works properly in Linux in general, and with Steam particularly (so it can have proper permission management and things like that).

//EDIT: depending on your desktop environment, you can also have a possibility to help you mount your drive more easily.


Yeah, i investigate a little and found out that the drives have to be mounted, for that i use the “GNOME Disks” application. I format the drive to be EXT4 for better compatibility with Linux and put the option to “Mount at system startup” but it doesn’t seem to work, or maybe I configure something wrong. Either way, i will try the post you send me. Thanks a lot!!

Oh, I’m reading the post you send me and realize that the application mount my drive as temporary, because in the directory instead of put “/media/” it’s says “/mnt/”. So yeah, the drive is temporary, i have to do the method you gave me.

I don’t use GNOME Disk to mount drives. However if you use KDE as your profile suggest, you can do that more easily as I said. Look in System Settings → Removable Storage → Removable Devices, if I recall correctly you can add auto mounting here too, if you already mounted the drive from the file manager I think (I’m looking at it, I think you would need to tick all the boxes).

//EDIT: and then when your drive auto mounts on boot, access it from the file manager to see the path you need to use for Steam.

//EDIT2: also if you have done something from GNOME Disk, it may interfere, I’m not sure what you did so I can’t comment on that.

Oh, I find it, but the problem it’s that my drive isn’t external (sorry, i might have to clarify that before), so it doesn’t appear on the removable devices (besides that, I checked all the boxes, just in case).

And what i did on GNOME Disk was Format the drive, make it EXT4 partition, given it a label, and mounted from the application and marked an option to Mount on boot.

Then maybe it is already properly mounting on boot. What is the content of /etc/fstab file? When you share text/terminal output/script and so on, please put the text between three backticks so it is properly formatted, like this:

content here

I tried to put the command in my terminal but it gave me this:
zsh: permission denied: /etc/fstab

It is a file not a command to execute in terminal, browse to the folder /etc/ in your file manager, and open the file fstab with a text editor, and copy the content here. if you want to open it from the terminal you can, execute nano /etc/fstab command.

PS: it is not backticks you typed, copy/paste what I wrote, see the difference of '''characters you typed and ``` I typed. Alternatively, have an empty line before the block of text you will copy paste, select it all, and click the </> button so it will do the same thing.

Oh, ok, sorry jaja. I’m passing the text of the file:

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=0CBD-A4BB                            /boot/efi      vfat    umask=0077 0 2
UUID=4e1b0433-8602-47a5-9d18-e0dc3f10f9fc /              ext4    defaults,noatime 0 1
UUID=2916ef1d-d8ff-4e21-8ace-5e419cacbc60 swap           swap    defaults,noatime 0 0
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
/dev/disk/by-label/JUEGOS /mnt/JUEGOS auto nosuid,nodev,nofail,x-gvfs-show 0 0
LABEL=Manjaro\040Extra+ /mnt/Manjaro\040Extra+ auto nosuid,nodev,nofail,x-gvfs-show,x-gvfs-name=Extras%2B 0 0
/dev/disk/by-label/Extras+ /mnt/Extras+ auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-label/Games /mnt/Games auto nosuid,nodev,nofail,x-gvfs-show 0 0

Sorry for that, i don’t have a key there, my keyboard is a little odd but it work copy/pasting it.
As for the drives i have two drives (I format the partition numerous times so maybe it keep the information to boot them but they don’t exist), the one that we are searching for it’s the one called “Games”

You continue to not do what I said, please edit your post (under the ... button, click the pen), add a blank line before the content you copied, and put the correct characters as I shown.

So how many disks do you have? Your fstab file apparently is meant to mount multiple ones (additionally of the system ones).

disk called JUEGOS
disk called Manjaro Extra+
disk called Extras+
disk called Games

I don’t know if i can delete the other disks apart from Games? So that the system doesn’t boot needlessly the other disks that don’t exist anymore.

If the only secondary disk you have is the one called Games I assume it is safe to remove the other lines referring the non existent disks.

BEWARE, this file is a very important system file, and messing it can/will crash your system, especially if you touch the other lines.

In theory then you should remove these lines:

/dev/disk/by-label/JUEGOS /mnt/JUEGOS auto nosuid,nodev,nofail,x-gvfs-show 0 0
LABEL=Manjaro\040Extra+ /mnt/Manjaro\040Extra+ auto nosuid,nodev,nofail,x-gvfs-show,x-gvfs-name=Extras%2B 0 0
/dev/disk/by-label/Extras+ /mnt/Extras+ auto nosuid,nodev,nofail,x-gvfs-show 0 0

and only these lines.

Then you should reboot, and see in Steam if you can add your disk for the library creation, its location should be at /mnt/Games so browse to this location when adding the new library from the Steam file manager.

//EDIT: I suggest you use a text editor like Kate, to open the file /etc/fstab so it is simpler to save it (it will ask for password elevated privilege to be able to save your modification in this system file).

1 Like

DONE!! Thank you so much, and sorry for all the problems! :smiley: :smiley:

1 Like

All good


1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.