I can't change language in phosh

I’m a Manjaro XFCE user who recently bought a pinephone and installed phosh on it,
as there’s no XFCE based phone desktop environment,
but I’m no longer used to GNOME since the GNOME3/MATE/Cinnamon split,
so I have no idea where to look for language settings.

I found it, however it doesn’t have any effect.
Settings -> '<-' -> Region & Languages