I can't boot to Windows from Manjaro

Hi, I just installed Manjaro but when I try to boot back to Windows 10 it just boot directly to Manjaro, I has already the grub menu before installing Manjaro but it dissapear, how can I boot back to Windows?

Hi, you need to add a line to the /etc/default/grub file.

Look up for similar threads like “osprober is disabled by default” and you’ll find the required line and how to add it.

See below:

Good luck!

By the way, be sure you haven’t installed Manjaro in BIOS mode, while Windows was in UEFI mode (or the other way around).

I think I installed Manjaro on UEFI, I have Windows installed on Legacy, what can I do?

I have that too, it’s not an issue for me as I never log on Windows anymore…

To eventually boot on Windows, at manufacturer’s logo I press on F10 (or F2 maybe) to go into the boot options. I have listed my BIOS/legacy entries (Windows included, so) or my UEFI entries (my Manjaro installs). You should have an equivalent method.

If really you want have both available in Grub, you’ll have to reinstall Windows in UEFI. Or reinstall Manjaro in bios/legacy.

1 Like

Oh thanks, I spent hours searching on forums of how to boot to Windows and it was as easy as selecting it with boot menu, I thought that that menu only switches between devices, not OSs.

Windows BIOS/legacy installation can be converted to UEFI without reinstallation, see
A backup is highly recommended.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.