I can't add a new printer (several problems...)

I bought recently a Xerox C235 multifuctional lazer printer to replace a Canon inkjet printer (it was working perfectly). I connected it to the local network via ethernet. I’m trying to add it to my Manjaro machine, but every way I try fails…

First I tried to add it via the gui tool “printers” in the systems settings. The printer is discovered (Connection: IPP network printer via DNS-SD), drivers after the search found, but after I hit apply I get “CUPS server error internal error” message.
A solution I found regarding a line a have to add nsswitch.conf file, is no good for me because the line I’m supposed to add to nsswitch.conf file it’s already there.

Then I tried to add the printer via the CUPS web interface (localhost:631). Again the printer discovered normaly, I chose a ppd from the list but at the last step when I click add printer I get “unable to copy PPD file” error message. The same message with all 3 ppd files I found relative to C235 printer.

Finally, I downloaded a ppd file from Xerox web page. I manually added it via the CUPS web interface and yes, the printer was added! But then I wanted to print a test page to check that everything was ok and nothing happened. The page didn’t printed. I got an error message again: “unable to locate printer”. The printer is visible but I can’t print.

Do you have any idea for any of the above please?

(From a windows machine and a mac machine that are connected to the same network, I was able to print. The same from my android phone. Also it’s the first time in history that I don’t have problem scanning. I can scan without problems…)

In my linux machine I run: Manjaro Cinnamon edition (cinnamon version: 5.4.3), kernel 5.17.15-1MANJARO and CUPS version installed is 2.4.2.

Thanks in advance for your time!

Setup the printer using a static IP - this is usually done by using the printers physical control panel.

Another option to configure the ip address is the printers web interface. To locate the printer’s current IP address - probably DHCP assigned - you can use arp-scan.

sudo pacman -Syu arp-scan


sudo arp-scan -l

You will see all devices on the network Open a web brrowser and point it to the IP address you think is your printer.

When that is in place - you can add the printer in cups webinterface ipp://v.x.y.z

Using DNS-SD requires the avahi daemon to be up and running

systemctl enable --now avahi-daemon.service avahi-dnsconfd.service avahi-daemon.socket