I cant access WiFi at all for some reason

I am a complete noob when it comes to anything besides installing programs in arch but i’ve installed manjaro yesterday right before i went to sleep but today i tried using WiFi instead of Ethernet for my main pc as i need ethernet for my secondary pc(that works just fine) too but i only have 1 ethernet connection and at first i could see wifi networks but when i tried accessing mine it would repeatedly ask me for the password. after a little research i came across someone saying that typing sudo nano /etc/conf.d/wireless-regdom and uncommenting my country code or something and restart my pc, after which my wifi was just gone entirely even after undoing it and restarting again. And now im stuck on ethernet. btw please ignore my bad english

General system info would be beneficial:
inxi -Fazy

What would really provide insight is a log copy of the time in between you attempting to connect - and it failing.

journalctl -f
in a terminal
then try to connect and wait until it fails

post all the output that appeared in the terminal in the mean time

It will contain clues as to why the connection failed to be established.

well inxi -Fazy outputs

 Kernel: 6.6.10-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
   clocksource: tsc available: hpet,acpi_pm
   parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
   root=UUID=91180889-93b8-4706-872a-519e05d2166e rw quiet splash
 Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 wm: kwin_x11 vt: 2
   dm: SDDM Distro: Manjaro Linux base: Arch Linux
 Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
 Mobo: ASUSTeK model: ROG STRIX B650-A GAMING WIFI v: Rev 1.xx
   serial: <superuser required> UEFI: American Megatrends v: 1654
   date: 08/25/2023
 Info: model: AMD Ryzen 5 7600X bits: 64 type: MT MCP arch: Zen 4 gen: 5
   level: v4 note: check built: 2022+ process: TSMC n5 (5nm) family: 0x19 (25)
   model-id: 0x61 (97) stepping: 2 microcode: 0xA601203
 Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
   L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 6 MiB desc: 6x1024 KiB
   L3: 32 MiB desc: 1x32 MiB
 Speed (MHz): avg: 2366 high: 4839 min/max: 400/5453 scaling:
   driver: amd-pstate-epp governor: powersave cores: 1: 3225 2: 400 3: 400
   4: 3535 5: 400 6: 3502 7: 3223 8: 400 9: 400 10: 4839 11: 3720 12: 4356
   bogomips: 112621
 Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
 Type: gather_data_sampling status: Not affected
 Type: itlb_multihit status: Not affected
 Type: l1tf status: Not affected
 Type: mds status: Not affected
 Type: meltdown status: Not affected
 Type: mmio_stale_data status: Not affected
 Type: retbleed status: Not affected
 Type: spec_rstack_overflow status: Vulnerable: Safe RET, no microcode
 Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
 Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
 Type: spectre_v2 mitigation: Enhanced / Automatic IBRS, IBPB: conditional,
   STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
 Type: srbds status: Not affected
 Type: tsx_async_abort status: Not affected
 Device-1: NVIDIA AD104 [GeForce RTX 4070] driver: nvidia v: 545.29.06
   alternate: nouveau,nvidia_drm non-free: 545.xx+
   status: current (as of 2023-11) arch: Lovelace code: AD1xx
   process: TSMC n4 (5nm) built: 2022+ pcie: gen: 4 speed: 16 GT/s lanes: 16
   bus-ID: 01:00.0 chip-ID: 10de:2786 class-ID: 0300
 Device-2: AMD Raphael vendor: ASUSTeK driver: amdgpu v: kernel arch: RDNA-2
   code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4
   speed: 16 GT/s lanes: 16 ports: active: none empty: DP-1,HDMI-A-1
   bus-ID: 0c:00.0 chip-ID: 1002:164e class-ID: 0300 temp: 49.0 C
 Device-3: Sunplus Innovation SPCA2281 Web Camera
   driver: snd-usb-audio,uvcvideo type: USB rev: 2.0 speed: 480 Mb/s lanes: 1
   mode: 2.0 bus-ID: 1-5:2 chip-ID: 1bcf:2281 class-ID: 0102 serial: <filter>
 Display: x11 server: X.Org v: 21.1.10 with: Xwayland v: 23.2.3
   compositor: kwin_x11 driver: X: loaded: amdgpu,modesetting,nouveau,nvidia
   alternate: fbdev,nv,vesa dri: radeonsi gpu: nvidia,amdgpu display-ID: :0
   screens: 1
 Screen-1: 0 s-res: 4480x1440 s-dpi: 108 s-size: 1054x342mm (41.50x13.46")
   s-diag: 1108mm (43.63")
 Monitor-1: DP-1 pos: bottom-r res: 1920x1080 hz: 60 dpi: 96
   size: 509x286mm (20.04x11.26") diag: 584mm (22.99") modes: N/A
 Monitor-2: DP-4 pos: primary,top-left res: 2560x1440 hz: 144 dpi: 109
   size: 597x336mm (23.5x13.23") diag: 685mm (26.97") modes: N/A
 Monitor-3: None-2-1 size-res: N/A modes: N/A
 API: EGL v: 1.5 hw: drv: nvidia drv: amd radeonsi platforms: device: 0
   drv: nvidia device: 1 drv: radeonsi device: 3 drv: swrast gbm:
   drv: kms_swrast surfaceless: drv: nvidia x11: drv: nvidia
   inactive: wayland,device-2
 API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.06
   glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 4070/PCIe/SSE2
   memory: 11.71 GiB
 API: Vulkan v: 1.3.274 layers: 5 device: 0 type: discrete-gpu
   name: NVIDIA GeForce RTX 4070 driver: nvidia v: 545.29.06
   device-ID: 10de:2786 surfaces: xcb,xlib device: 1 type: integrated-gpu
   name: AMD Radeon Graphics (RADV RAPHAEL_MENDOCINO) driver: mesa radv
   v: 23.3.3-manjaro1.1 device-ID: 1002:164e surfaces: xcb,xlib
 Device-1: NVIDIA driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s
   lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:22bc class-ID: 0403
 Device-2: AMD Rembrandt Radeon High Definition Audio vendor: ASUSTeK
   driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
   bus-ID: 0c:00.1 chip-ID: 1002:1640 class-ID: 0403
 Device-3: HP HyperX QuadCast S driver: hid-generic,snd-usb-audio,usbhid
   type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-12.4:12
   chip-ID: 03f0:0294 class-ID: 0300
 Device-4: Sunplus Innovation SPCA2281 Web Camera
   driver: snd-usb-audio,uvcvideo type: USB rev: 2.0 speed: 480 Mb/s lanes: 1
   mode: 2.0 bus-ID: 1-5:2 chip-ID: 1bcf:2281 class-ID: 0102 serial: <filter>
 Device-5: ASUSTek USB Audio driver: hid-generic,snd-usb-audio,usbhid
   type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-6:3
   chip-ID: 0b05:1a52 class-ID: 0300
 API: ALSA v: k6.6.10-1-MANJARO status: kernel-api with: aoss
   type: oss-emulator tools: alsactl,alsamixer,amixer
 Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
 Server-2: JACK v: 1.9.22 status: off tools: N/A
 Server-3: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
   status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
   tools: pactl,pw-cat,pw-cli,wpctl
 Device-1: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel pcie:
   gen: 2 speed: 5 GT/s lanes: 1 port: N/A bus-ID: 08:00.0 chip-ID: 8086:15f3
   class-ID: 0200
 IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
 Device-2: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
   vendor: Foxconn driver: N/A modules: mt7921e pcie: gen: 2 speed: 5 GT/s
   lanes: 1 bus-ID: 09:00.0 chip-ID: 14c3:0616 class-ID: 0280
 Device-1: Foxconn / Hon Hai Wireless_Device driver: btusb v: 0.8 type: USB
   rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-11:7 chip-ID: 0489:e0e2
   class-ID: e001 serial: <filter>
 Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
 Local Storage: total: 3.7 TiB used: 29.14 GiB (0.8%)
 SMART Message: Unable to run smartctl. Root privileges required.
 ID-1: /dev/nvme0n1 maj-min: 259:3 vendor: Crucial model: CT1000P5SSD8
   size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
   lanes: 4 tech: SSD serial: <filter> fw-rev: P4CR311 temp: 41.9 C
   scheme: GPT
 ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Kingston model: SKC3000D2048G
   size: 1.86 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
   lanes: 4 tech: SSD serial: <filter> fw-rev: EIFK31.6 temp: 29.9 C
   scheme: GPT
 ID-3: /dev/sda maj-min: 8:0 vendor: Intenso model: SSD SATAIII
   size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
   tech: SSD serial: <filter> fw-rev: 5A0 scheme: GPT
 ID-1: / raw-size: 953.57 GiB size: 937.53 GiB (98.32%) used: 29.14 GiB (3.1%)
   fs: ext4 dev: /dev/sda2 maj-min: 8:2
 ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
   used: 296 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
 Alert: No swap data was found.
 System Temperatures: cpu: 55.5 C mobo: N/A gpu: amdgpu temp: 50.0 C
 Fan Speeds (rpm): N/A
 Processes: 340 Uptime: 1h 24m wakeups: 0 Memory: total: 16 GiB note: est.
 available: 14.78 GiB used: 9.12 GiB (61.7%) Init: systemd v: 255
 default: graphical tool: systemctl Compilers: gcc: 13.2.1 alt: 12
 clang: 16.0.6 Packages: pm: pacman pkgs: 1359 libs: 357 tools: pamac
 pm: flatpak pkgs: 0 Shell: Zsh v: 5.9 default: Bash v: 5.2.21
 running-in: konsole inxi: 3.3.31

and then at the second one i have the problem that there are no WiFi networks at all anymore so i cant test that.

Thats very difficult to read.
Please try


1 Like

well i just tried editing the text and when i wanted to save it i got an error 422
ok i fixed that error


sudo rmmod mt7921e
sudo modprobe mt7921e


systemctl restart NetworkManager

Oh, and I found an Arch thread that mentioned patches … but it is from months ago …

And lastly theres also this possibly related AUR package.