I can't access my USB stick

I wanted to install manjaro running live in another USB on my USB stick. There was a problem during the installation phase and it was not continued.

Then I inserted and removed the USB stick. The USB stick is no longer visible and inaccessible with the “lsblk” command a few seconds after it is first plugged in.

I tried to repair it with the fdisk command, but after entering this command, it waits for a few seconds without doing anything and says USB not detected.
(fdisk: cannot open /dev/sdb: No such file or directory)

how can i solve this problem?

First of all, you need to provide more information, like which program u used to burn that image, what kind of firmware ur pc has (like BIOS or UEFI) the device names of the drive and the usb and stuff like that, check this thread for more information. [HowTo] Provide System Information

Now coming to your problem, you have not specified the problem!

What I can think of, is that you’ve accidently choosed the usb instead of the drive on calamares. Or that you’ve choosed the wrong option on the boot menu (choose the one containing “UEFI”, if you can).

Now it’s not that I’m not actually helping you, it’s just that you need to provide more information as said above, or no one can. Cheers ! :beers:

You tried to install on the same disk where you are currently running Manjaro. This will of course fail because one of the first steps is formatting the drive.
The keyword for you to look for is persistent installation on a USB drive.

I could be mistaken - but I don’t think Calamares support install to removable devices.

You would need to do a manual install using CLI.

you will find some usable links here (even when the text is german, google translate may help):

and here:

No, I tried to install manjaro on a 2nd USB. Manjaro’s already live bootable USB is fine. I just wanted to install manjaro on USB and the USB I wanted to install had a problem

Command (m for help): d
Selected partition 1
Partition 1 has been deleted.

Command (m for help): w
The partition table has been altered.
**Here it waits for a few seconds, but gives the following warning without the write operation.** 

Calling ioctl() to re-read partition table.
Re-reading the partition table failed.: No such device or address

The kernel still uses the old table. The new table will be used at the next reboot or after you run partprobe(8) or partx(8).