I cannot print after update, even after enable cups service manually

Hi everybody,

I have a problem with the printing system in Manjaro KDE

  • At the beginning I had no issues with my printer, everything was working flawless. BTW the printer is a Samsung ML-1660

  • After a system update (I think it was in the first week of February or maybe the last one of January), I noticed that I couldn’t print anything. I didn’t think it was very important, commonly those kind of errors are fixed in following updates.

  • I knew the problem was not the printer because I could print through a virtual machine

  • But now, that another update and kernel has been released and installed and I still cannot print anything I’m here asking for help.

  • Every time that I try to print something, a led in the printer starts blinking (like it’s getting ready to print) but then nothing happens, and if I try to do it a second time then the printer pulls a sheet of paper and print something, but all that a get is an almost-blank printing with this message:

INTERNAL ERROR - Including Corrupted Data
POSITION : 0x1bd3c (113980) - - This changes every try - -
SYSTEM : h6fw_5.37_01/x1_image
LINE : 154
VERSION : SPL 5.37.01 10-05-2010

  • It doesn’t matter the kind of file that is sent (or even if is a test print) the behavior is always the same

  • I’ve tried to enable the CUPS service manually doing

systemctl enable --now cups.service
systemctl enable --now cups.socket
systemctl enable --now cups.path

  • I’ve removed and added the printer several times

  • Even I’ve tried removing and reinstalling CUPS hoping that would help, but I’ve had no luck

Any help will be appreciated

Are you sure it was that late? There was an update in December which resulted in cups needing manual intervention

1 Like

If @sawdoctor 's excellent advice didn’t work (tell us if it did) how did you do this:

because the standard is not to remove any config files, whereas your issue looks a lot like a bad config file…


1 Like

Hi @sawdoctor ,

Yeah I’m sure that this issue started this year, actually in January I printed a lot of things and I always do my best to have my system updated.

I already tried to run the same commands you mention, but basically I get the same results.

[josh@manjaro ~]$ sudo systemctl disable --now org.cups.cupsd.socket        
Failed to disable unit: Unit file org.cups.cupsd.socket does not exist.
[josh@manjaro ~]$ sudo systemctl disable --now org.cups.cupsd.service
Failed to disable unit: Unit file org.cups.cupsd.service does not exist.
[josh@manjaro ~]$ sudo systemctl disable --now org.cups.cupsd.path
Failed to disable unit: Unit file org.cups.cupsd.path does not exist.
[josh@manjaro ~]$ sudo systemctl enable --now cups.service     
[josh@manjaro ~]$ sudo systemctl enable --now cups.socket
[josh@manjaro ~]$ sudo systemctl enable --now cups.path
[josh@manjaro ~]$ sudo systemctl enable --now cups
[josh@manjaro ~]$ pacman -Ql cups | grep systemd
cups /usr/lib/systemd/
cups /usr/lib/systemd/system/
cups /usr/lib/systemd/system/cups-lpd.socket
cups /usr/lib/systemd/system/cups-lpd@.service
cups /usr/lib/systemd/system/cups.path
cups /usr/lib/systemd/system/cups.service
cups /usr/lib/systemd/system/cups.socket
[josh@manjaro ~]$ ls -lR /etc/systemd/ | grep cups
lrwxrwxrwx 1 root root 33 feb 23 20:01 cups.path -> /usr/lib/systemd/system/cups.path
lrwxrwxrwx 1 root root 36 feb 23 20:01 cups.service -> /usr/lib/systemd/system/cups.service
lrwxrwxrwx 1 root root 35 feb 23 20:01 cups.socket -> /usr/lib/systemd/system/cups.socket
[josh@manjaro ~]$

The main issue is that the system apparently has no problem identifying the hardware, it always detects and installs automatically the printer every time I remove it from the system and connect it again, I can see the printer ready to print in any program, but every time I try to send something I get the same, those error lines and no more.

I don’t know, maybe for some reason I need to change to that new cupsd thing, but I have no idea how to do that.

Hi @Fabby ,

The way I do that (using octopi) is looking for any package with the word ‘cups’ in it and removing it, I clean the cache and then I restart the system to check whether there is or not a printing service running, and once I see there’s no way to even detect the printer I reinstall them all and restart again. only to watch how the printer is auto detected and installed again, but without printing capabilities.

I’m pretty newby in this, and maybe I’m achieving nothing doing that, but that’s what I’ve tried in order to solve the issue.

From your description it looks like you removed all the binaries, but not the configs and in that case, --no-save is your friend…

pamac remove --no-save cups*


pamac install cups

If even that doesn’t save it, look for e .ppd file for your Samsung ML-1660 on Samsungs’s web site or community site and use that instead.


1 Like

Ok, let me try that and then I’ll report the results

I’ve tried both things.

First, I tried the --no-save command and after reinstall CUPS I was able to print, but my happiness didn’t last because after a few prints I got again the same error message.

After that, I tried to choose a different .pdd file but now is weirder because the printer works randomly, sometimes works and sometimes don’t

Do you still have Windows in dual boot, because with all of the above, I’m suspecting a printer hardware failure (does it stop working when the printer is hot?)


Yes I have, but the thing is that I also have a virtual machine with Windows 7, and I’ve been able to print from there without problems, before and after every try :sob:

In that case, I’m officially out of bright ideas, unfortunately!


1 Like

Well, thank you very much anyway, I guess my only remaining hope is that this problem can be solved magically by itself in some coming update (exactly as it started)
:sweat_smile: :+1:

1 Like