I cannot get Firefox to launch in Sikaris

I am running a fresh install of Manjaro Sikaris, KDE edition. All apps, configs, etc. were put there by the installer. I have not added or changed anything.

Nothing happens when I attempt to launch the Firefox app that was included in the install (version 108.0.1-1 according to pamac).

If I click the launcher on the bar at the bottom I see circle around the icon, and it seems to display progress of some sort, but the browser never shows on the screen.

If I try to launch Firefox from the command line I get no response whatsoever. There is no output from the program, and no error information. It doesn’t even return me to a prompt unless I use Clrl + C. Waiting doesn’t help the situation any. I’ve waited for over 10 minutes (according to zsh) and still no browser.

What I’ve tried so far

  • I’ve seen posts about similar problems suggesting that there is something wrong within ~/.mozilla. I removed that folder and launched Firefox again. The folder gets recreated, but Firefox still fails to launch as before.
  • I’ve also seen posts suggesting that removing Firefox and reinstalling it would fix the issue. I removed Firefox, I reinstalled it, and there was no change.
  • I tried combining these two approaches. I removed Firefox, removed ~/.mozilla, and then reinstalled Firefox. It still won’t launch.
  • Some posts suggested there is something wrong with the default profile. I tried launching Firefox with firefox -p, as it was my understanding that doing so would allow me to choose or create a new profile. Firefox still did not launch, and there was no opportunity to choose a profile.

Can anyone suggest something else I might try?

===== UPDATE =====
I tried running Firefox from the command line once more. This would be the 6th or 7th try. Anyway, this time it launched! There was also some output which may or may not be useful if anyone else encounters this problem. That output is:
[GFX1-]: glxtest: VA-API test failed: no supported VAAPI profile found.
ATTENTION: default value of option mesa_glthread overridden by environment.

None of the suggested options applied to me. The first doesn’t fit because there Firefox does launch, but in my case it does not. Same goes for the second option. There they stated that they could launch with firefox -p, but in my case this did not work.

I updated my original post to indicate that the problem went away. Unfortunately, that didn’t last long, and I had to look for a solution again. I kept experimenting and eventually found something which worked for me. I’ll leave that solution here in case it is useful to someone else. I found that if I launched Firefox with firefox --migration then this immediately pulled up a wizard for importing bookmarks (you can skip importing if you want to). Once that was done Firefox itself came up and ran, and it’s been fine ever since. I can launch Firefox normally and have no more problems with it.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.