Firefox starts, but won't open new window

When attempting to start Firefox, no new Window or tab will appear, as if the program failed to launch. However, Firefox can clearly be seen running in the System Monitor Overview. Even if i kill that process, and try to launch it again normally, it will still fail to open. Firefox can still be opened through the terminal though, using firefox -p.

“If you already know the solution, then why are you making this post?”
Well, I’m making this post because this really isn’t much of a solution, just a work-around. And besides, i shouldn’t need to open the terminal just to do something i should be able to do with a single click. This issue started occurring about 2 weeks ago, after a system update. I didn’t make a post about it until now, because 1; i wanted to see if i could solve it myself first and 2; This issue only happened sometimes , and wasn’t too big of a deal to me.
Now, after yet another system update, this issue seems to happen any time i initially open Firefox.

Things I’ve already tried:

  1. Re-installing Firefox
  2. Clearing Firefox cache
  3. Deleting all profiles and absolutely resetting everything

Note: Once Firefox has been opened from the terminal properly, it can then be opened from the taskbar/task manager Normally.

System info here

So yeah, I’ve tried everything i could think of, and I’m kinda clueless as to how to proceed with this issue.

Any help with this issue would be much appreciated.

Hi @EndLord,

Please provide any output from when you open Firefox the first time from the terminal:


And not

firefox -p

You are correct that it’s only a workaround and not a real fix, but to fix it, we’ve got to know what is wrong, so that it can be fixed.

You may have a look at this thread where you can find some possible solutions … or not !

Alright, i’ll be sure to take a look at that.

I ran firefox in the terminal, and no output was given, but firefox was indeed running, but without any GUI elements appearing at all. Same with firefox -p.
It is to the point which i need to launch Firefox manually from the system installed binary, and sometimes even that won’t work. What i hate most is the inconsistency of this issue.

My apologies for the super late response.

OK, so let’s try the next thing. Please provide the output of the following:

journalctl --boot=-1 --grep 'firefox' --no-pager


  • The --boot=-1 arguments just limits the messenges to be searched to the previous boot’s;
  • the --grep 'firefox' arguments searches the messages specified by the --boot argument forr any mention of “firefox”;
  • the --no-pager argument just causes journalctl to output all the messages at once, without need to human interaction. Making it better to supply here.

Here’s the output:

   ~  journalctl --boot=-1 --grep 'firefox' --no-pager                                       ✔ 
Dec 28 15:11:32 user-manjaro systemd[1253]: Started Firefox - Web Browser.
Dec 28 15:11:33 user-manjaro dbus-daemon[1280]: [session uid=1000 pid=1280] Activating via systemd: service name='org.a11y.Bus' unit='at-spi-dbus-bus.service' requested by ':1.59' (uid=1000 pid=2109 comm="/usr/lib/firefox/firefox")
Dec 28 16:41:36 user-manjaro systemd[1253]: app-firefox-1fc0ae6c6c544fca9d62090b817f892d.scope: Consumed 43min 28.303s CPU time.
Dec 28 17:51:49 user-manjaro systemd[1253]: Started Firefox - Web Browser.
Dec 28 18:44:31 user-manjaro systemd[1253]: app-firefox-c2bfe293f9fe400f807deded1563be75.scope: Consumed 22min 11.649s CPU time.
Dec 28 20:33:20 user-manjaro systemd[1253]: Started Firefox - Web Browser.
Dec 28 20:37:01 user-manjaro systemd[1253]: app-firefox-2f6665fc22da4e418bd01d6d1c063ae3.scope: Consumed 1min 14.667s CPU time.
Dec 28 20:46:28 user-manjaro systemd[1253]: Started Firefox - Web Browser.
Dec 28 22:18:06 user-manjaro systemd[1253]: app-firefox-efb30665c6cd41f4a709960dd4ab64eb.scope: Consumed 40min 52.094s CPU time.
    ~                                                                                                                              

The dates are all from the 28th because i did a system cleanup and deleted old logs. I didn’t think they would be relevant to this issue. Right now the issue seems to come and go. Firefox is working fine right now, but for all i know it might not work properly tomorrow.

Here’s the output from the command. This time though, i ran the command right after i witnessed the issue occur.

    ~  journalctl --boot=-1 --grep 'firefox' --no-pager                                                                                                                                                                             ✔ 
Dec 29 03:19:16 user-manjaro systemd[1297]: Started Firefox - Web Browser.
Dec 29 03:19:17 user-manjaro dbus-daemon[1324]: [session uid=1000 pid=1324] Activating via systemd: service name='org.a11y.Bus' unit='at-spi-dbus-bus.service' requested by ':1.61' (uid=1000 pid=2238 comm="/usr/lib/firefox/firefox")
Dec 29 04:39:11 user-manjaro systemd[1297]: app-firefox-99346b6c077c4c2dbaa24c6501d0e975.scope: Consumed 34min 29.406s CPU time.
Dec 29 05:28:50 user-manjaro systemd[1297]: Started Firefox - Web Browser.
Dec 29 09:52:21 user-manjaro systemd[1297]: app-firefox-78cc5c62ce384a9db0230b1516e4d36d.scope: Consumed 53min 37.050s CPU time.
Dec 29 09:57:48 user-manjaro systemd[1297]: Started Firefox - Web Browser.
Dec 29 10:32:19 user-manjaro systemd[1297]: app-firefox-48180b7df2194a70b136c427a1569fe2.scope: Consumed 29min 20.506s CPU time.
Dec 29 13:29:39 user-manjaro systemd[1297]: Started Firefox - Web Browser.
Dec 29 15:53:08 user-manjaro systemd[1297]: app-firefox-6a58adcbe33041e4b892a9354248be04.scope: Consumed 40min 35.386s CPU time.

Hmmm…OK, I don’t see anything. But that doesn’t mean there’s nothing there. Other people might see something I don’t, so thanks. But since it’s kind of obscured, let’s see what we catch if we broaden the net a little. Please provide the output of:

journalctl --boot=-1 --priority=4 --no-pager


  • The --boot= arguments limits the scope of the logs to the previous boot, -1. Feel free to adjust it to -2 for the boot before that, -3 for the one before that, and so on, and so forth. Adjust it to the last boot this occurred.
  • The --priority=4 argument limits the output to be only warnings and errors.
  • The --no-pager argument you remember from previously. Probably.

If this doesn’t reveal anything extra, there’s possibly something else we can try to figure it out, but I’m completely unsure if it’ll reveal anything.

Alright, here’s the output log. It’s quite the long one.

I just want to say; thank you for taking the time to explain what the command arguments do, it really helps make things more clear and I’m learning things along the way :slight_smile:

I didn’t see anything Firefox related in the output, but like you said, somebody else might see something we don’t.

Yeah, me neither. I don’t know what to do from here, but let’s see if someone else does.

You are welcome! I know I’d have appreciated it when I was still learning. Heck, I am still learning. So there’s no reason why other people won’t.