I can no longer put transparency in Manjaro Plasma terminal

As the title says, in the current version of Plasma from Manjaro I can no longer put transparency in the background of my terminal, which is my preferred tool for almost all system maintenance tasks.

My hardware information:

[benedito@benedito ~]$ inxi -Fazy
System:
  Kernel: 5.15.94-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.15-x86_64
    root=UUID=86fa2618-e926-4e3a-9d22-2aa498203272 rw rootflags=subvol=@ quiet
    udev.log_priority=3
  Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Desktop System: Hewlett-Packard product: HP Compaq 6005 Pro SFF PC
    v: N/A serial: <superuser required> Chassis: type: 4
    serial: <superuser required>
  Mobo: Hewlett-Packard model: 3047h serial: <superuser required>
    BIOS: Hewlett-Packard v: 786G6 v01.12 date: 02/02/2011
CPU:
  Info: model: AMD Phenom II X2 B55 bits: 64 type: MCP arch: K10 level: v1
    built: 2009-13 process: AMD 45nm family: 0x10 (16) model-id: 4 stepping: 3
    microcode: 0x10000C8
  Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 256 KiB
    desc: d-2x64 KiB; i-2x64 KiB L2: 1024 KiB desc: 2x512 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 800 min/max: 800/3000 boost: disabled scaling:
    driver: acpi-cpufreq governor: schedutil cores: 1: 800 2: 800 bogomips: 11974
  Flags: ht lm nx pae sse sse2 sse3 sse4a svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass status: Not affected
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD RS880 [Radeon HD 4200] vendor: Hewlett-Packard driver: radeon
    v: kernel arch: TeraScale code: R6xx/RV6xx/RV7xx process: TSMC 55-65nm
    built: 2005-13 ports: active: DP-1 empty: VGA-1 bus-ID: 01:05.0
    chip-ID: 1002:9710 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.7 compositor: kwin_x11 driver: X:
    loaded: radeon unloaded: modesetting alternate: fbdev,vesa dri: r600
    gpu: radeon display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1280x720 s-dpi: 96 s-size: 338x190mm (13.31x7.48")
    s-diag: 388mm (15.27")
  Monitor-1: DP-1 mapped: DisplayPort-0 model: Panasonic PANASONIC-TV
    serial: <filter> built: 2006 res: 1280x720 hz: 60 dpi: 47 gamma: 1.2
    size: 697x392mm (27.44x15.43") modes: max: 1280x720 min: 640x480
  API: OpenGL v: 3.3 Mesa 22.3.5 renderer: AMD RS880 (DRM 2.50.0 /
    5.15.94-1-MANJARO LLVM 15.0.7) compat-v: 3.0 direct-render: Yes
Audio:
  Device-1: AMD SBx00 Azalia vendor: Hewlett-Packard driver: snd_hda_intel
    v: kernel bus-ID: 00:14.2 chip-ID: 1002:4383 class-ID: 0403
  Sound API: ALSA v: k5.15.94-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.22 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.65 running: yes
Network:
  Device-1: Broadcom NetXtreme BCM5761 Gigabit Ethernet PCIe
    vendor: Hewlett-Packard driver: tg3 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: N/A bus-ID: 3f:00.0 chip-ID: 14e4:1681 class-ID: 0200
  IF: enp63s0 state: down mac: <filter>
  Device-2: Realtek RTL8188FTV 802.11b/g/n 1T1R 2.4G WLAN Adapter type: USB
    driver: rtl8188fu bus-ID: 2-4:2 chip-ID: 0bda:f179 class-ID: 0000
    serial: <filter>
  IF: wlp0s19f2u4 state: up mac: <filter>
Drives:
  Local Storage: total: 465.77 GiB used: 22.03 GiB (4.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST3250318AS
    size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: HP34 scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST3250318AS
    size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: HP34 scheme: MBR
Partition:
  ID-1: / raw-size: 50 GiB size: 50 GiB (100.00%) used: 13.44 GiB (26.9%)
    fs: btrfs dev: /dev/sdb1 maj-min: 8:17
  ID-2: /home raw-size: 174.88 GiB size: 174.88 GiB (100.00%)
    used: 8.59 GiB (4.9%) fs: btrfs dev: /dev/sdb3 maj-min: 8:19
  ID-3: /var/log raw-size: 50 GiB size: 50 GiB (100.00%)
    used: 13.44 GiB (26.9%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 34.2 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 194 Uptime: 11m wakeups: 0 Memory: 15.13 GiB
  used: 2.09 GiB (13.8%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman
  pkgs: 1247 libs: 357 tools: pamac pm: flatpak pkgs: 0 Shell: Bash v: 5.1.16
  running-in: konsole inxi: 3.3.25
[benedito@benedito ~]$ 


As you can see in the image above, the edit button is disabled, thanks in advance for suggestions.

T+ = See you later

The default Konsole profile in Manjaro Plasma is read-only. You need to copy it with a new name, then edit that copy, and set it as the default profile to be used. :wink:

1 Like

A simple utility to make an active window transparent is

transset-df

For example type this command in a terminal after downloading and installing:

transset-df -t -a

The -t is a toggle
The -a does it without clicking on the window.

I use this on my Netflix lappy to quickly check the time on the desktop without having to reduce the full screen window. You can create a little script with a hot key.

(Not sure this works in Wayland.) The docs only say X11.

Yes, but let’s see until the next update, it always goes back to Breath

But let’s see the next stable branch update

Thank’s

T+ = See you later

1 Like

You can also make a window transparent by scrolling your mouse wheel on its titlebar. Just make sure you have the mouse action enabled via:

System Settings => Window Management => Window Behavior => Titlebar Actions => Mouse Wheel => Change Opacity

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.