I am very very VERY impressed version 2

There was/is a couple of threads discussing GPT/MBR/bios/efi setups. There is the newly developed install-grub script etc.

About GPT/bios, I took the stance “if you decide to run this strange setup it’s on you to figure out how to hande it”.

3 Day ago I got handed a HP G62 laptop (I think was the name, I already returned it so I do not have an inxi for you, but it is OLD, and I mean OLD AF, 2010, 13 years old)

Battery non functional (not charging so the cmos gets emptied), fan sounded like a broken tuba when starting at full power, 4GB of memory, no efi available, could NOT find a bios update that worked so Im stuck at the 2010 version instead of the 2012 firmware, but the laptop was in good physical condition otherwise.
I did find 3:rd party bios with efi I could try, but fk it, I do not want to risk bricking it with a random ass firmware from a strange website.

I was thinking of trying linux mint on it but decided to try Manjaro xfce.

As I said I was an outspoken advocate AGAINST these kinds of setups (GPT/bios) but I wanted to try btrfs on it and I THINK I need GPT for that, so I formatted the drive and created a new partition table in GPT.
Selected manual partitioning in Calamares, created root, separate home partition (both in btrfs) and a swap and pressed next. Calmares TOLD ME TO CREATE A 8MiB unformatted partition at the beginning of the disk marking it with lba so I pressed back and did that.

Continued with the install and after a little while “reboot now” > reboot > “welcome to manjaro”. :open_mouth:

Wanted to do the initial setup with mirrors but mark my surprise when I got certificate errors on every single mirror, but they also responded with a ping, super confusing.
I could NOT surf most of the web, I had no idea what was going on.
Searching the forum presented users with the similar problems but to smaller extent, ie only one or two of the mirrors returned with error, for me, I did not get a single mirror.

In one of the threads someone suggested to go to a manjaro webpage (don’t remember witch one now, but that is less important) and in firefox it informed me “your time seems to be a bit off”, and yes, the cmos is constantly emptying so my hwclock is set to jan 2010 and I did not think about it, it was one of those “I fix that after the update”.
I changed the time to use online servers to sync instead and voila, EVERYTHING worked.
One of the threads are still open “waiting for a solution”, I might go and respond to it, but it is from 2022, so… I’ll think about it.

After that, all I had to do was set up timeshift, change the wifi driver with the help of users here on the forum and I was done.
Went to my friend that owns the laptop last night and I showed him the ropes, installing whatever he wanted, discord, torrent server/interface, network share, spotify (AUR) etc etc and he was blown away.
He told me “I NEVER thought I would see this laptop again, I thought you just wanted it for hardware parts or something”.

Just for fun, I had a windows7 live usb (microsoft calls them something else, but it is literally a live usb) and booted with it to see if he maybe wanted to use windows anyway, he laughed me out of the house.

HOLY CRAP that a +10 year old laptop “just works” (kinda) running linux66 without problems!

I :clap: AM :clap: SO :clap: FREAKIN’ :clap: AMAZED :clap:

Since it is in the feedback part of the forum, there was one thing I was not satisfied with that I did not mention above.

manjaro-zsh-config is installed in the install of a full version of Manjaro xfce, but it is not activated.
Using chsh also changed the tty:s promt witch result in a tiny ~ > prompt.
Solved it with the help of this forum and 3 lines of code in .zshrc.
But it would be nice if it was like in KDE plasma where zsh is used in gui and bash in tty, or even get the option to choose in the installation process somehow.

I have a PC from Sept. 2012. It works just fine (UEFI). Why wouldn’t it?


Calm yourself, @bedna – it’s Linux – how could you not think it would work as planned?! All that’s needed is a little love and understanding! :heart_eyes_cat:


Yeah, my bad for trying to give positive feedback I guess. sigh
I’m honestly considering removing the post.

Enthusiasm is always welcoming. Leave it there. :wink:

I had a 15 year old laptop that just worked with Debian… :smile:

Of course, that was about 15 years ago.