I am unable to delete a file that is using space in my usb pendrive and not showing that fille

a file that is using 4GB on my pendrive is not showing.
how to delete that?

Quick and pragmatic solution:
copy/backup everything you need from what is currently on the drive
then reformat the drive -
this time use a filesystem that can hold files larger than 4 GB
which is the file size limit of fat32.

Would it happen to start with a dot?

ls -la /path/to/folder

I was copying a .7z file to the pendrive but due to unsufficient space it stopped and gave an error but now the space is not freed and the file is not showing too.

Please provide the list of files in the target folder with the command above.

can you please tell me in easier language.
i am new to manjaro

  • Open a terminal
  • Copy the command there, and adapt it to your case whenever necessary
  • Execute with Enter
  • Copy/Paste the result here – don’t forget to use preformatting!

i ran the command ls -la in the folder where pendrive is present
it gives me

total 87440
drwxr-xr-x  6 satyamv satyamv    16384 Jan  1  1970  .
drwxr-x---+ 3 root    root          60 Feb 19 15:46  ..
drwxr-xr-x  9 satyamv satyamv    16384 Feb 16 17:58 'chemistry lectures'
drwxr-xr-x  7 satyamv satyamv    16384 Feb 17 05:54 'Maths lectures'
drwxr-xr-x  7 satyamv satyamv    16384 Feb 16 17:59 'Physics lecutes'
-rw-r--r--  1 satyamv satyamv 89441928 Feb 17 19:41 'Resonance Online AITS 2020.zip'
drwxr-xr-x  5 satyamv satyamv    16384 Feb  5 07:08 "topper's books"

My approach re an issue like this on a pendrive would be:

  • a file, taking up space, should be there - but it isn’t

  • therefore, no file can be deleted, which in turn means that the space cannot be regained

  • but I want the space back

  • if there is a fsck tool for the filesystem on the drive, check and possibly repair the filesystem

if that doesn’t yield a positive result:

  • copy everything off of the drive
  • then reformat the drive/create a new filesystem
  • then copy back the saved files


Well, the file you started to paste there is not in the list, so there it is not.
Actually, i think it makes sense, since if a copy cannot complete due to missing space, it should be entirely cancelled and the space freed.

But since you say freed it is not, i wonder if it isn’t just the file manager not handling correctly the disk usage information. Have you tried to unmount/remont the pendrive – without forcing! – and see if the memory information is updated?

Alternatively, you can use a disk usage tool to check how the space is used:

du -h /path/to/mount

Deleting a file through a file manager usually moves it to the bin, instead of outright deleting it, thus the situation you are describing.
But you should still be able to directly delete that file with rm.

Plug the USB drive back in, using the file manager, empty the trash…see what happens.

i have 32 GB of pendrive but the dolphin says it is of 28.6 GB
but all the files that are there sum to only 24.1 GB and still showing 514.5 MB left