Hybrid video laptop second monitor not working

HP Pavilion Gaming AMD Ryzen 4800; Kernel 5.15.12-1 Plasma desktop. Currently shown installed drivers are video-hybrid-amd-nvidia-prime both for the AMD onboard graphics and the NVidia 1650 Ti. On Windows 10 (dual boot) no problem running a second monitor. Under Manjaro the second monitor shows up under Hardware Configuration/Display and Monitor. Enable it as a replica of the laptop screen and nothing happens, no video to it-- have done pretty extensive reading here on these problems and am at a loss. I show the option of installing the video-hybrid-amd-nvidia-470xx-prime drivers as an update. Curious about whether this will go towards resolving the problem. Have also tried enabling/disabling TLP and that makes no difference still no video on the second monitor. Suggestions? Update to the 470 drivers?

update-- updated the drivers to the 470 package, no difference… Checked BIOS settings to make sure nothing was disabled —didnt think anything would be since everything works on Windows…so am at somewhat of a loss…

Another update. Upgraded to the 5.16 rc6 kernel since reading over on Ubuntu about some success there with the AMD/NVidia combination. As I do more research I will post here but so far its either pretty lame that this wont work…or that Hybrid is still much more of a work in progress than a feature in Manjaro.

xrandr -q shows both the internal monitor and the connected monitors. xrandr --listproviders shows both the AMD and the NVidia adapters. Then from this NVidia thread


running nvidia-xconfig --prime, says the tool, after being unable to locate an Xconfig file for prime, creates one. It then asks that “xrandr --setprovideroutputsource modesetting NVIDIA-0” and “xrandr --auto” be run. Output of the first is that “could not find provider with name modesetting”…output of the second “xrandr: Configure crtc 4 failed”…Reboot and now even with the failure messages both monitors are functional.

Couple of notes. Re enabled TLP, re booted connected to the power supply and still functional on both monitors. Shut down, disconnected power and re booted and both monitors still function as before. What this means is that I am going to have to research settings in TLP to disable the NVidia adapter on batter- what I want for my configuration.

What seemed to have solved the problem was in sifting through a lot of threads, coming across the Nvidia information from their website and running nvidia-xconfig --prime. Took a bit to find this but its all good, it all works…
Hope this might help someone.


Having the same problem here on my AMD/nVidia 3070 Omen 15. Thanks for the update, i’ll be following here.
nvidia-xconfig --prime would mean you are always running the nvidia which is not good for the battery and the card?

Anyway, does this now work without error warnings?

I’ve also tried the [optimus](https://wiki.manjaro.org/index.php/Optimus_Manager) solution. Didn’t work for me.